SUEXEC(8) BSD System Manager's Manual SUEXEC(8)
suexec - switch user for Apache CGI execution
suexec is the "wrapper" support program for the suexec behaviour for the Apache httpd(8) server. It is run from within the server automatically to switch the user when an external program has to be run under a different user. The options are as follows: -V Display the list of compile-time settings used when suexec was built. No other action is taken. Because this program is only used internally by httpd(8), there are no other ways to directly invoke suexec. In order to work correctly, the suexec binary should be owned by "root" and have the SETUID execution bit set. OpenBSD currently does not install suexec with the SETUID bit set, so a change of file mode is necessary to enable it: # chmod u+s /usr/sbin/suexec
httpd(8) Apache suEXEC Support: /var/www/htdocs/manual/suexec.html MirOS BSD #10-current March 19, 2008 1
Generated on 2014-02-10 02:47:05 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.