RENICE(8) BSD System Manager's Manual RENICE(8)
renice - alter priority of running processes
renice priority [[-p] pid ...] [[-g] pgrp ...] [[-u] user ...]
renice alters the scheduling priority (an integer) of one or more running processes. The following who parameters (pid, pgrp and user) are inter- preted as process IDs, process group IDs, or user names. reniceing a pro- cess group causes all processes in the process group to have their scheduling priority altered. reniceing a user causes all processes owned by the user to have their scheduling priority altered. By default, the processes to be affected are specified by their process IDs. The options are as follows: -g Force who parameters to be interpreted as process group IDs. -u Force the who parameters to be interpreted as user names. -p Resets the who interpretation to be (the default) process IDs. For example, # renice +1 987 -u daemon root -p 32 would change the priority of process IDs 987 and 32, and all processes owned by users daemon and root. Users other than the superuser may only alter the priority of processes they own, and can only monotonically increase their "nice value" within the range 0 to PRIO_MAX (20). (This prevents overriding administrative fiats.) The superuser may alter the priority of any process and set the priority to any value in the range PRIO_MIN (-20) to PRIO_MAX. Useful priorities are: 20 (the affected processes will run only when nothing else in the system wants to), 0 (the "base" scheduling priority), any- thing negative (to make things go very fast).
/etc/passwd for mapping user names to user IDs
nice(1), getpriority(2), setpriority(2)
The renice command appeared in 4.0BSD.
Non-superusers cannot increase scheduling priorities of their own processes, even if they were the ones that decreased the priorities in the first place. MirOS BSD #10-current June 9, 1993 1
Generated on 2015-10-06 19:36:22 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.