NTPD(8) BSD System Manager's Manual NTPD(8)
ntpd - Network Time Protocol daemon
ntpd [-dSst] [-f file]
The ntpd daemon synchronizes the local clock to one or more remote NTP servers, and can also act as an NTP server itself, redistributing the lo- cal time. It implements the Simple Network Time Protocol version 4, as described in RFC 2030, and the Network Time Protocol version 3, as described in RFC 1305. ntpd uses the adjtime(2) system call to correct the local system time without causing time jumps. Adjustments are logged using syslog(3). Leap seconds are accounted correctly on MirOS using the libc tai_leaps(3) facility. However, NTP will not survive the year 2038. ntpd is usually started at boot time, and can be enabled by setting the following in /etc/rc.conf.local: ntpd_flags="" See rc(8) and rc.conf(8) for more information on the boot process and enabling daemons. When ntpd starts up, it reads settings from a configuration file, typi- cally ntpd.conf(5). The options are as follows: -d Do not daemonize. If this option is specified, ntpd will run in the foreground and log to stderr. -f file Use file as the configuration file, instead of the default /etc/ntpd.conf. -S Do not set the time immediately at startup. This is the de- fault. This option is deprecated. -s Set the time immediately at startup if the local clock is off by more than 180 seconds. Allows for a large time correction, eliminating the need to run rdate(8) before starting ntpd. This option is deprecated. -t Trace information about the peer(s) used for adjusting. Use several times for more information, unless running with -d.
/etc/ntpd.conf default ntpd configuration file ntpd throws away all previously received replies from all peers and sends out two queries quickly to re-sync when it receives SIGUSR1.
date(1), adjtime(2), ntpd.conf(5), rc(8), rc.conf(8), rdate(8), taitime(3), timed(8) Network Time Protocol (Version 3), RFC 1305, March 1992. Simple Network Time Protocol (SNTP) Version 4, RFC 2030, October 1996.
The ntpd program first appeared in OpenBSD 3.6. Support for correct leap second handling was added in MirOS #8. Trace and serverloop support was added in MirOS #10. The -s and -S options were re- moved and SIGUSR1 handling was added in MirOS #11. MirOS BSD #10-current November 22, 2009 1
Generated on 2015-07-19 22:36:15 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.