NFSD(8) BSD System Manager's Manual NFSD(8)
nfsd - remote NFS server
nfsd [-rtu] [-n num_servers]
nfsd runs on a server machine to service NFS requests from client machines. At least one nfsd must be running for a machine to operate as a server. Unless otherwise specified, four servers for UDP transport are started. The options are as follows: -n num_servers Specifies how many servers to create (max 20). -r Register the NFS service with portmap(8) without creating any servers. This option can be used along with the -u or -t options to re-register NFS if the portmap server is restarted. -t Serve TCP NFS clients. -u Serve UDP NFS clients. For example, "nfsd -u -t -n 6" serves UDP and TCP transports using six daemons. A server should run enough daemons to handle the maximum level of con- currency from its clients, typically four to six. nfsd listens for service requests at the port indicated in the NFS server specification; see Network File System Protocol Specification, RFC 1094 and NFS: Network File System Version 3 Protocol Specification. On MirOS systems, this is always port 2049, or NFS_PORT (defined in <nfs/nfsproto.h>). The nfsd utility exits 0 on success or >0 if an error occurred.
nfsstat(1), nfssvc(2), mountd(8), portmap(8)
The nfsd utility first appeared in 4.4BSD. MirOS BSD #10-current March 29, 1995 1
Generated on 2014-02-10 02:47:05 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.