MOUNT_PROCFS(8) BSD System Manager's Manual MOUNT_PROCFS(8)
mount_procfs - mount the process file system
mount_procfs [-o options] /proc mount_point
The mount_procfs command attaches an instance of the process namespace to the global filesystem namespace. The conventional mount point is /proc. This command is normally executed by mount(8) at boot time. The options are as follows: -o options Options are specified with a -o flag followed by a comma separat- ed string of options. See the mount(8) man page for possible op- tions and their meanings. The following procfs specific option is also available: linux Add Linux compatibility links and nodes to procfs. The root of the process filesystem contains an entry for each active pro- cess. These processes are visible as a directory whose name is the process's PID. In addition, the special entry curproc references the current process. Each directory contains several files. cmdline Process command line parameters, separated by NULs. ctl A write-only file which supports a variety of control operations. Control commands are written as strings to the ctl file. The con- trol commands are: attach Stops the target process and arranges for the sending process to become the debug control process. detach Continues execution of the target process and removes it from control by the debug process (which need not be the sending process). run Continues running the target process until a signal is delivered, a breakpoint is hit, or the target process ex- its. step Single steps the target process, with no signal delivery. wait Waits for the target process to come to a steady state ready for debugging. The target process must be in this state before any of the other commands are allowed. The string can also be the name of a signal, lower case and without the SIG prefix, in which case that signal is delivered to the process (see sigaction(2)). file A reference to the vnode from which the process text was read. This can be used to gain access to the process's symbol table, or to start another copy of the process. fpregs The floating point registers as defined by struct fpregs in <machine/reg.h>. fpregs is only implemented on machines which have distinct general purpose and floating point register sets. mem The complete virtual memory image of the process. Only those ad- dress which exist in the process can be accessed. Reads and writes to this file modify the process. Writes to the text seg- ment remain private to the process. note Not implemented. notepg Not implemented. regs Allows read and write access to the process's register set. This file contains a binary data structure struct regs defined in <machine/reg.h>. regs can only be written when the process is stopped. status The process status. This file is read-only and returns a single line containing multiple space-separated fields as follows: • Command name. • Process ID. • Parent process ID. • Process group ID. • Session ID. • major,minor of the controlling terminal, or -1,-1 if there is no controlling terminal. • List of process flags: ctty if there is a controlling termi- nal, sldr if the process is a session leader, or noflags if neither of the other two flags are set. • Process start time in seconds and microseconds, comma separated. • User time in seconds and microseconds, comma separated. • System time in seconds and microseconds, comma separated. • Wait channel message. • Process credentials consisting of the effective user ID and the list of groups (whose first member is the effective group ID), all comma separated. In a normal debugging environment, where the target is fork/exec'd by the debugger, the debugger should fork and the child should stop itself (with a self-inflicted SIGSTOP for example). The parent should issue a wait and then an attach command via the appropriate ctl file. The child process will receive a SIGTRAP immediately after the call to exec (see execve(2)). Statistics reported by df(1) on a procfs filesystem will indicate virtual memory used/available instead of 'disk space', and the number of process slots used/allocated instead of 'inodes'. The block size of the filesys- tem is the system page size.
/proc/# /proc/curproc /proc/curproc/cmdline /proc/curproc/ctl /proc/curproc/file /proc/curproc/fpregs /proc/curproc/mem /proc/curproc/note /proc/curproc/notepg /proc/curproc/regs /proc/curproc/status
mount(2), sigaction(2), sysctl(3), fstab(5), mount(8), umount(8)
The mount_procfs utility first appeared in 4.4BSD.
This filesystem may not be NFS-exported since most of the functionality of procfs requires that state be maintained. When changing the kern.allowpsa and/or kern.allowpse sysctl, this filesystem must be unmounted and remounted for the new permission bits to become active. MirOS BSD #10-current May 20, 2012 2
Generated on 2014-02-10 02:47:05 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.