MAKEMAP(8) BSD System Manager's Manual MAKEMAP(8)
makemap - create database maps for sendmail
makemap [-C file] [-N] [-c cachesize] [-D commentchar] [-d] [-e] [-f] [-l] [-o] [-r] [-s] [-t delim] [-u] [-v] maptype mapname
makemap creates the database maps used by the keyed map lookups in sendmail(8). It reads input from the standard input and outputs them to the indicated mapname. Depending on how it is compiled, makemap handles up to three different database formats, selected using the maptype parameter. They may be dbm DBM format maps. This requires the ndbm(3) library. btree B-Tree format maps. This requires the new Berkeley DB li- brary. hash Hash format maps. This also requires the Berkeley DB library. In all cases, makemap reads lines from the standard input consisting of two words separated by whitespace. The first is the database key, the second is the value. The value may contain ``%n'' strings to indicated parameter substitution. Literal percents should be doubled (``%%''). Blank lines and lines beginning with ``#'' are ignored. Notice: do not use makemap to create the aliases data base, but newaliases(8) which puts a special token into the data base that is re- quired by sendmail(8). If the TrustedUser option is set in the sendmail configuration file and makemap is invoked as root, the generated files will be owned by the specified TrustedUser.
-C file Use the specified sendmail(8) configuration file for looking up the TrustedUser option. -N Include the null byte that terminates strings in the map. This must match the -N flag in the sendmail.cf "K" line. -c Use the specified hash and B-Tree cache size. -D Use to specify the character to use to indicate a comment (which is ignored) instead of the default of '#'. -d Allow duplicate keys in the map. This is only allowed on B- Tree format maps. If two identical keys are read, they will both be inserted into the map. -e Allow empty value (right hand side). -f Normally all upper case letters in the key are folded to lower case. This flag disables that behaviour. This is in- tended to mesh with the -f flag in the "K" line in sendmail.cf. The value is never case folded. -l List supported map types. -o Append to an old file. This allows you to augment an existing file. -r Allow replacement of existing keys. Normally makemap com- plains if you repeat a key, and does not do the insert. -s Ignore safety checks on maps being created. This includes checking for hard or symbolic links in world writable direc- tories. -t Use the specified delimiter instead of white space (also for dumping a map). -u dump (unmap) the content of the database to standard output. -v Verbosely print what it is doing.
editmap(8), newaliases(8), sendmail(8)
The makemap command appeared in 4.4BSD. MirOS BSD #10-current December 31, 2012 1
Generated on 2014-02-10 02:47:05 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.