LOGIN_PASSWD(8) BSD System Manager's Manual LOGIN_PASSWD(8)
login_passwd - provide standard password authentication type
login_passwd [-s service] [-v wheel=yes|no] [-v lastchance=yes|no] user [class]
The login_passwd utility is called by login(1), su(1), ftpd(8), and oth- ers to authenticate the user with passwd-style authentication. The user argument is the login name of the user to be authenticated. The service argument specifies which protocol to use with the invoking program. The allowed protocols are login, challenge, and response. (The challenge protocol is silently ignored but will report success as passwd-style authentication is not challenge-response based). If the wheel argument is specified and is not set to "yes", then the user will be rejected as not being in group "wheel". This is used by su(1). If the lastchance argument is specified and is equal to "yes", then if the user's password has expired, and it has not been expired longer than "password-dead" seconds (see login.conf(5)), the user will be able to log in one last time to change the password. login_passwd will prompt the user for a password and report back to the invoking program whether or not the authentication was successful.
login(1), passwd(1), su(1), login.conf(5), ftpd(8) MirOS BSD #10-current December 11, 2000 1
Generated on 2015-10-25 00:47:46 by $MirOS: src/scripts/roff2htm,v 1.81 2015/10/16 13:19:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by mirabilos.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.