LMCCTL(8) BSD System Manager's Manual LMCCTL(8)
lmccontrol - configure Lan Media Corporation SSI/HSSI/T1/T3 devices
lmccontrol [interface] [-l speed] [-cCeEsSkKoO]
The lmccontrol command controls the operation of the Lan Media devices via the lmc(4) driver. Most of the parameters that can be changed relate to the line characteristics or layer 2 protocol options. You can adjust layer 2 protocol keepalives, and line speed. Line characteristics which can be adjusted include CRC length, internal or external clock source, DS3 scrambler, and DS3 cable length. This program controls the Lan Media SSI, HSSI, T1, and DS3 network inter- faces. The SSI is the LMC1000, and runs at various speeds up to 10Mbps. It requires an external CSU/DSU for operation on T1/E1 lines. The HSSI card is the LMC5000, and runs at various speeds up to 52Mbps. It requires an external DSU for operation on DS3 lines. The DS3 is the LMC5245 and runs at a speed of 45Mbps. It has no internal clock generator, and does not require external DSU for DS3 operation. The T1 card is the LMC1200 and runs at a speed of 1.544Mbps or 2Mbps for E1 operation, without CSU/DSU. The [interface] argument given to lmccontrol should be the logical inter- face name associated with the Lan Media device (lmc0, lmc1, etc...). The lmccontrol command given without any additional flags retrieves the current card settings from the driver and prints them out. The options are as follows: interface The interface name of the Lan Media card (default is lmc0). -l speed To manually specify line speed, in bits per second (for devices without built-in CSU/DSU). -c Sets the interface to use an external clock source. This is only valid for SSI/HSSI cards. -C Set the interface to use internal clocking. On the SSI card this uses the internal baud rate generator. On the HSSI card it uses the PCI bus clock. This is only valid for SSI/HSSI cards. -e Sets 16-bit CRC. -E Sets 32-bit CRC. -k Enables layer 2 keepalive. -K Disables layer 2 keepalive. -s Turn DS3 scrambler off. -S Turn DS3 scrambler on. -o Program the DS3 card for cable lengths of less than 100 feet. In this mode, the card uses lower power to transmit data for short cable runs, which might otherwise overdrive a receiver. This is the default, and will work in most situations even with runs more than 100 feet. -O Program the DS3 card for cable length for over 100 feet in length (higher power).
To set a SSI card for a speed of 2048000 bits/sec with HDLC keepalive off, one could use: # lmccontrol lmc0 -l 2048000 -K
lmc(4), sppp(4), hostname.if(5), ifconfig(8), spppcontrol(8)
The lmccontrol utility first appeared in OpenBSD 2.8.
The lmccontrol utility was written by Michael Graff <firstname.lastname@example.org>. MirOS BSD #10-current October 11, 2000 1
Generated on 2015-07-19 22:36:15 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.