DEV_MKDB(8) BSD System Manager's Manual DEV_MKDB(8)
dev_mkdb - create /dev database
The dev_mkdb command creates a db(3) hash access method database in "/var/run/dev.db" which contains the names of all of the character and block special files in the "/dev" directory, using the file type and the st_rdev field as the key. Keys are a structure containing a mode_t followed by a dev_t, with any padding zeroed out. The former is the type of the file (st_mode & S_IFMT), the latter is the st_rdev field.
/dev device directory /var/run/dev.db database file
ps(1), stat(2), db(3), devname(3), kvm_nlist(3), ttyname(3), kvm_mkdb(8)
The dev_mkdb command appeared in 4.4BSD. MirOS BSD #10-current June 6, 1993 1
Generated on 2015-10-06 19:36:22 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.