CCDCONFIG(8) BSD System Manager's Manual CCDCONFIG(8)
ccdconfig - configuration utility for the concatenated disk driver
ccdconfig [-cv] ccd ileave flags dev [...] ccdconfig -C [-v] [-f config_file] ccdconfig -u [-v] ccd [...] ccdconfig -U [-v] [-f config_file] ccdconfig -g [-M core] [-N system] [ccd [...]]
ccdconfig is used to dynamically configure and unconfigure concatenated disk devices, or ccds. For more information about the ccd, see ccd(4). The options are as follows: -c Configure a ccd. This is the default behavior of ccdconfig. -C Configure all ccd devices listed in the ccd configuration file. -f config_file When configuring or unconfiguring all devices, read the file config_file instead of the default /etc/ccd.conf. -g Dump the current ccd configuration in a format suitable for use as the ccd configuration file. If no arguments are specified, every configured ccd is dumped. Otherwise, the configuration of each listed ccd is dumped. Only root can dump the configuration (unless ccdconfig is made setgid kmem). -M core Extract values associated with the name list from core instead of the default /dev/mem. -N system Extract the name list from system instead of the running kernel. -u Unconfigure a ccd. -U Unconfigure all ccd devices listed in the ccd configuration file. -v Causes ccdconfig to be verbose. A ccd is described on the command line and in the ccd configuration file by the name of the ccd, the interleave factor, the ccd configuration flags, and a list of one or more devices. The flags may be represented as a decimal number, a hexadecimal number, a comma-separated list of strings, or the word "none". The flags are as follows: CCDF_SWAP 0x01 Interleave should be dmmax. CCDF_UNIFORM 0x02 Use uniform interleave. CCDF_MIRROR 0x04 Enable data mirroring. CCDF_OLD 0x08 Use old unoptimized I/O protocol. The format in the configuration file appears exactly as if it were en- tered on the command line. Note that on the command line and in the con- figuration file, the flags argument is optional. # # /etc/ccd.conf # Configuration file for concatenated disk devices # # ccd ileave flags component devices ccd0 16 none /dev/sd2e /dev/sd3e
/etc/ccd.conf default ccd configuration file
The following command, executed from the command line, would configure ccd0 with 4 components (/dev/sd2e, /dev/sd3e, /dev/sd4e, /dev/sd5e), and an interleave factor of 32 blocks. # ccdconfig ccd0 32 0 /dev/sd2e /dev/sd3e /dev/sd4e /dev/sd5e
The ccdconfig command first appeared in NetBSD 1.0A. MirOS BSD #10-current July 17, 1995 1
Generated on 2015-10-06 19:36:22 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.