ARP(8) BSD System Manager's Manual ARP(8)
arp - address resolution display and control
arp [-n] hostname arp [-n] -a arp -d hostname arp -d -a arp [-F] -s hostname ether_addr [temp | permanent] [pub] arp [-F] -f filename
The arp program displays and modifies the Internet-to-Ethernet address translation tables used by the address resolution protocol (arp(4)). With no flags, the program displays the current ARP entry for hostname. The host may be specified by name or by number, using Internet dot notation. Available options: -a Display all of the current ARP entries. See also the -d option below. -d Delete an entry for the host called hostname. Alternatively, the -d flag may be combined with the -a flag to delete all entries, with hostname lookups automatically disabled. Only the superuser may delete entries. -F Force existing entries for the given host to be overwritten (only relevant to the -f and -s options). -f Process entries from filename to be set in the ARP tables. Any entries in the file that already exist for a given host will not be overwritten unless -F is given. Entries in the file should be of the form: hostname ether_addr [temp | permanent] [pub] The entry will be static, i.e., will not time out, unless the word temp is given in the command. A static ARP entry can be overwritten by network traffic, unless the word permanent is given. If the word pub is given, the entry will be "published"; i.e., this system will act as an ARP server, responding to re- quests for hostname even though the host address is not its own. This behavior has traditionally been called proxy ARP. -n Show network addresses as numbers (normally arp attempts to display addresses symbolically). -s hostname ether_addr [temp | permanent] [pub] Create an ARP entry for the host called hostname with the Ether- net address ether_addr. The Ethernet address is given as six hex- adecimal bytes separated by colons. Lines beginning with '#' are considered comments and are ignored. The permanent, pub, or temp modifiers may be specified with mean- ings as given above. If the entry already exists for the given host, it will not be replaced unless -F is given.
To view the current arp(4) table: $ arp -a To create a permanent entry (one that cannot be overwritten by other net- work traffic): # arp -s 10.0.0.2 00:90:27:bb:cc:dd permanent To create proxy ARP entries on an interface, fxp0, for the IP addresses 22.214.171.124 and 126.96.36.199: # arp -s 188.8.131.52 00:90:27:bb:cc:dd pub # arp -s 184.108.40.206 00:90:27:bb:cc:dd pub (where 00:90:27:bb:cc:dd is the MAC address of fxp0)
inet(3), arp(4), ifconfig(8)
The arp command appeared in 4.3BSD. MirOS BSD #10-current July 14, 1999 1
Generated on 2016-04-09 18:24:16 by $MirOS: src/scripts/roff2htm,v 1.83 2016/03/26 23:38:28 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2016 The MirOS Project, Germany.
This product includes material provided by mirabilos.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.