ALIASES(5) BSD Reference Manual ALIASES(5)
aliases - aliases file for sendmail
This file describes user ID aliases used by /usr/sbin/sendmail. The file resides in /etc/mail and is formatted as a series of lines of the form name: addr_1, addr_2, addr_3, . . . The name is the name to alias, and the addr_n are the aliases for that name. addr_n can be another alias, a local username, a local filename, a command, an include file, or an external address. Local Username username The username must be available via getpwnam(3). Local Filename /path/name Messages are appended to the file specified by the full pathname (starting with a slash (/)) Command |command A command starts with a pipe symbol (|), it receives messages via standard input. Include File :include: /path/name The aliases in pathname are added to the aliases for name. E-Mail Address user@domain An e-mail address in RFC 2822 format. Lines beginning with whitespace are continuation lines. Another way to continue lines is by placing a backslash directly before a newline. Lines beginning with '#' are comments. Aliasing occurs only on local names. Loops can not occur, since no mes- sage will be sent to any person more than once. If an alias is found for name, sendmail then checks for an alias for owner-name. If it is found and the result of the lookup expands to a sin- gle address, the envelope sender address of the message is rewritten to that address. If it is found and the result expands to more than one ad- dress, the envelope sender address is changed to owner-name. After aliasing has been done, local and valid recipients who have a ".forward" file in their home directory have messages forwarded to the list of users defined in that file. This is only the raw data file; the actual aliasing information is placed into a binary format in the file /etc/mail/aliases.db using the program newaliases(8). A newaliases command should be executed each time the aliases file is changed for the change to take effect.
dbm(3), dbopen(3), newaliases(8), sendmail(8)
The aliases file format appeared in 4.0BSD.
If you have compiled sendmail with DBM support instead of NEWDB, you may have encountered problems in dbm(3) restricting a single alias to about 1000 bytes of information. You can get longer aliases by ``chaining''; that is, make the last name in the alias be a dummy name which is a con- tinuation alias. MirOS BSD #10-current June 9, 2014 1
Generated on 2016-04-09 18:24:16 by $MirOS: src/scripts/roff2htm,v 1.83 2016/03/26 23:38:28 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2016 The MirOS Project, Germany.
This product includes material provided by mirabilos.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.