USCANNER(4) BSD Programmer's Manual USCANNER(4)
uscanner - minimal USB support for scanners
uscanner* at uhub? port ? configuration ?
The uscanner driver provides minimal support for USB scanners. The driver recognizes a number of USB scanners, but to actually scan anything there needs to be software that knows about the particular scanner. The SANE package provides support for some scanners.
The uscanner driver works with the following scanners:
GT-7000 Perfection 610U Perfection 636U Perfection 1200U Perfection 1200U Photo
ScanJet 4100C ScanJet 5200C ScanJet 5300C ScanJet 6300C
ScanMaker X6USB Many other scanners are recognized, but there is no software support for them yet.
intro(4), uhub(4), usb(4) http://www.buzzard.org.uk/jonathan/scanners-usb.html
The uscanner driver appeared in NetBSD 1.6. OpenBSD support was first ad- ded in OpenBSD 2.9.
This driver should not really exist. The scanners it recognizes can be accessed through the ugen(4) driver instead. A proper scanner driver would provide a uniform interface to scanners instead of exposing the in- nards of the scanner. The reason the driver exists is to have something that is compatible with the Linux driver. MirOS BSD #10-current September 10, 2000 1
Generated on 2015-10-25 00:47:46 by $MirOS: src/scripts/roff2htm,v 1.81 2015/10/16 13:19:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by mirabilos.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.