TL(4) BSD Programmer's Manual TL(4)
tl - Texas Instruments ThunderLAN Ethernet driver
tl* at pci? dev ? function ?
The tl driver provides support for PCI Ethernet adapters based on the Texas Instruments ThunderLAN Ethernet controller chip. This includes a large number of Compaq PCI-bus Ethernet adapters as well as the integrat- ed Ethernet controllers built in to several models of Compaq Prosignia servers and Compaq Deskpro desktop machines. This driver also supports the Olicom OC-2135/2138, OC-2325 and OC-2326 10/100 TX UTP adapters and the Racore 8165 10/100baseTX and 8148 10baseT/100baseTX/100baseFX multi- personality cards. The ThunderLAN controller has a standard MII interface that supports up to 32 physical interface devices (PHYs). It also has a built-in 10baseT PHY hardwired at MII address 31, which may be used in some 10Mbps-only hardware configurations. In 100Mbps configurations, a National Semicon- ductor DP83840A or other MII-compliant PHY may be attached to the ThunderLAN's MII bus. If a DP83840A or equivalent is available, the Thun- derLAN chip can operate at either 100Mbps or 10Mbps in either half-duplex or full-duplex modes. The ThunderLAN's built-in PHY and the DP83840A also support autonegotiation. The tl driver supports the following media types: autoselect Enable autoselection of the media type and options. Note that this option is only available on those PHYs that sup- port autonegotiation. Also, the PHY will not advertise those modes that have been explicitly disabled using the following media options. 10baseT Set 10Mbps operation. 100baseTX Set 100Mbps (Fast Ethernet) operation. 10base5 Enable AUI/BNC interface (useful only with the built-in PHY). The tl driver supports the following media options: full-duplex Force full duplex operation. half-duplex Force half duplex operation. hw-loopback Enable hardware loopback mode. Note that the 100baseTX media type is only available if supported by the PHY. For more information on configuring this device, see ifconfig(8).
tl%d: couldn't map memory A fatal initialization error has occurred. tl%d: couldn't map interrupt A fatal initialization error has occurred. tl%d: device timeout The device has stopped responding to the network, or there is a problem with the network connection (cable). tl%d: no memory for rx list The driver failed to allocate an mbuf for the receiver ring. tl%d: no memory for tx list The driver failed to allocate an mbuf for the transmitter ring when allocating a pad buffer or collapsing an mbuf chain into a cluster.
arp(4), ifmedia(4), intro(4), netintro(4), pci(4), hostname.if(5), ifconfig(8)
The tl device driver first appeared in FreeBSD 2.2. OpenBSD support first appeared in OpenBSD 2.4.
The tl driver was written by Bill Paul <email@example.com>. MirOS BSD #10-current May 1, 1998 1
Generated on 2015-10-06 19:36:22 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.