TI(4) BSD Programmer's Manual TI(4)
ti - Alteon Networks Tigon I and II Gigabit Ethernet driver
ti* at pci? dev ? function ?
The ti driver provides support for PCI Gigabit Ethernet adapters based on the Alteon Networks Tigon Gigabit Ethernet controller chip. The Tigon contains an embedded R4000 CPU, Gigabit MAC, dual DMA channels and a PCI interface unit. The Tigon II contains two R4000 CPUs and other refine- ments. Either chip can be used in either a 32-bit or 64-bit PCI slot. Communication with the chip is achieved via PCI shared memory and bus master DMA. The Tigon I and II support hardware multicast address filter- ing, VLAN tag extraction and insertion, and jumbo Ethernet frames sizes up to 9000 bytes. Note that the Tigon I chipset is no longer in active production: all new adapters should come equipped with Tigon II chipsets. There are several PCI boards available from both Alteon and other vendors that use the Tigon chipset under OEM contract. The ti driver has been tested with the following Tigon-based adapters: • The Alteon AceNIC V Gigabit Ethernet adapter (1000baseSX) • The Alteon AceNIC V Gigabit Ethernet adapter (1000baseT) • The 3Com 3C985-SX Gigabit Ethernet adapter (Tigon 1) • The 3Com 3C985B-SX Gigabit Ethernet adapter (Tigon 2) • The Netgear GA620 Gigabit Ethernet adapter (1000baseSX) • The Netgear GA620T Gigabit Ethernet adapter (1000baseT) The following should also be supported but have not yet been tested: • The Digital EtherWORKS 1000SX PCI Gigabit Adapter • Silicon Graphics PCI Gigabit Ethernet adapter • Farallon PN9000SX Gigabit Ethernet adapter While the Tigon chipset supports 10, 100 and 1000Mbps speeds, support for 10 and 100Mbps speeds is only available on boards with the proper tran- sceivers. Most adapters are only designed to work at 1000Mbps, however the driver should support those NICs that work at lower speeds as well. Support for jumbo frames is provided via the interface MTU setting. Selecting an MTU larger than 1500 bytes with the ifconfig(8) utility con- figures the adapter to receive and transmit jumbo frames. Using jumbo frames can greatly improve performance for certain tasks, such as file transfers and data streaming. The ti driver supports the following media types: autoselect Enable autoselection of the media type and options. The user can manually override the autoselected mode by adding media options to the appropriate hostname.if(5) file. 10baseT Set 10Mbps operation The mediaopt option can also be used to select either full-duplex or half-duplex modes. 100baseTX Set 100Mbps (Fast Ethernet) operation. The mediaopt option can also be used to select either full-duplex or half-duplex modes. 1000baseSX Set 1000Mbps (Gigabit Ethernet) on fiber operation. Only full-duplex mode is supported at this speed. 1000baseT Set 1000Mbps (Gigabit Ethernet) on copper operation. The ti driver supports the following media options: full-duplex Force full duplex operation half-duplex Force half duplex operation For more information on configuring this device, see ifconfig(8).
ti%d: couldn't map memory A fatal initialization error has occurred. ti%d: couldn't map interrupt A fatal initialization error has occurred. ti%d: no memory for softc struct! The driver failed to allocate memory for per-device instance information during initialization. ti%d: failed to enable memory mapping! The driver failed to initialize PCI shared memory mapping. This might happen if the card is not in a bus-master slot. ti%d: no memory for jumbo buffers! The driver failed to allocate memory for jumbo frames during initialization. ti%d: bios thinks we're in a 64 bit slot, but we aren't The BIOS has programmed the NIC as though it had been installed in a 64-bit PCI slot, but in fact the NIC is in a 32-bit slot. This happens as a result of a bug in some BIOSes. This can be worked around on the Tigon II, but on the Tigon I initialization will fail. ti%d: board self-diagnostics failed! The ROMFAIL bit in the CPU state register was set after system startup, indicating that the on-board NIC diagnostics failed. ti%d: unknown hwrev The driver detected a board with an unsupported hardware revision. The ti driver supports revision 4 (Tigon 1) and revi- sion 6 (Tigon 2) chips and has firmware only for those devices. ti%d: watchdog timeout The device has stopped responding to the network, or there is a problem with the network connection (cable).
arp(4), ifmedia(4), intro(4), netintro(4), pci(4), hostname.if(5), ifconfig(8)
The ti device driver first appeared in FreeBSD 3.0. OpenBSD support first appeared in OpenBSD 2.6.
The ti driver was written by Bill Paul <firstname.lastname@example.org>. MirOS BSD #10-current March 4, 1999 1
Generated on 2015-07-19 22:36:15 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.