SW(4) BSD Programmer's Manual (SPARC) SW(4)
sw - NCR 5380 SCSI Weird Sun 4/100 on-board SCSI controller
sw0 at obio0 addr 0x0a000000 level 3 (sun4/100) #sw0 at obio0 addr 0x0a000000 level 3 flags 0x07 (sun4/100) scsibus* at sw?
The sw is the Sun 4/100 on-board SCSI controller based on the NCR 5380 chip, found only on Sun 4/100 workstations. The sw driver is actually im- plemented as part of the si(4) driver.
0x01 Use DMA (polled) 0x02 Use DMA completion interrupts 0x04 Allow disconnect/reconnect The sw device flags may be OR'd together to enable any combination of the features listed above. If no flags are specified, the device will use polled DMA by default.
cd(4), ch(4), esp(4), intro(4), scsi(4), sd(4), si(4), ss(4), st(4), uk(4)
The sw driver first appeared in NetBSD.
The sw driver only supports polled DMA at this time. MirOS BSD #10-current March 4, 1998 1
Generated on 2013-09-18 04:33:42 by $MirOS: src/scripts/roff2htm,v 1.77 2013/01/01 20:49:09 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2013 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.