OSIOP(4) BSD Programmer's Manual OSIOP(4)
osiop - Symbios/NCR 53C710 SCSI driver
osiop* at gsc? irq 9 (hppa) osiop0 at pcctwo0 offset 0x47000 ipl 2 (mvme88k) scsibus* at osiop?
The osiop driver provides support for the Symbios/NCR 53C710 SCSI con- troller chip. The Symbios/NCR 53C700 SCSI controller is handled by the oosiop(4) driver, while the Symbios/NCR 53C8xx PCI SCSI host adapters are handled by the siop(4) driver.
The osiop driver supports the following flags for use in config(8) files: bits 0-7: disable disconnect/reselect for the corresponding SCSI target bits 8-15: disable synchronous negotiation for SCSI target bits 16: disable DMA interrupts "Target" is synonymous with SCSI ID number. Note that SCSI tape drives should be allowed to perform disconnect/reselect or performance will suffer.
cd(4), ch(4), intro(4), oosiop(4), scsi(4), sd(4), siop(4), ss(4), st(4), uk(4) http://www.lsilogic.com/techlib/techdocs/storage_stand_prod/
The osiop driver first appeared in NetBSD 1.6. The original NCR 53C710 driver appeared in NetBSD 1.0 amiga port, and Izumi Tsutsui <firstname.lastname@example.org> modified the driver and made it machine-independent. MirOS BSD #10-current March 12, 2004 1
Generated on 2015-07-19 22:36:15 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.