MII(4) BSD Programmer's Manual MII(4)
mii - IEEE 802.3 Media Independent Interface
acphy* at mii? phy ? amphy* at mii? phy ? bmtphy* at mii? phy ? brgphy* at mii? phy ? dcphy* at mii? phy ? eephy* at mii? phy ? exphy* at mii? phy ? icsphy* at mii? phy ? inphy* at mii? phy ? iophy* at mii? phy ? lxtphy* at mii? phy ? mtdphy* at mii? phy ? nsgphy* at mii? phy ? nsphy* at mii? phy ? nsphyter* at mii? phy ? qsphy* at mii? phy ? rlphy* at mii? phy ? sqphy* at mii? phy ? tlphy* at mii? phy ? tqphy* at mii? phy ? txphy* at mii? phy ? ukphy* at mii? phy ? urlphy* at mii? phy ? xmphy* at mii? phy ?
Media Independent Interface is an IEEE standard serial bus for connecting MACs (network controllers) to PHYs (physical media interfaces). The mii layer allows network device drivers to share support code for various PHY models, and allows unused support for PHYs which are not present in a system to be removed from the kernel. Network device drivers which use the mii layer carry the "mii" autoconfi- guration attribute. This allows kernel configuration files to simply specify PHYs as described above in SYNOPSIS. The following is an example of the messages displayed when a network in- terface with an attached PHY is detected by the kernel: hme0 at sbus0 slot 1 offset 0x8c00000 pri 7: address 08:00:20:22:86:b8 rev 34 nsphy0 at hme0 phy 1: DP83840 10/100 media interface, rev. 1 ifconfig(8) can be used to display the media types supported by the PHY. These media types are valid media keywords for use with the ifconfig(8) program.
acphy(4), amphy(4), bmtphy(4), brgphy(4), dcphy(4), eephy(4), exphy(4), icsphy(4), ifmedia(4), inphy(4), intro(4), iophy(4), lxtphy(4), mtdphy(4), netintro(4), nsgphy(4), nsphy(4), nsphyter(4), qsphy(4), rlphy(4), sqphy(4), tlphy(4), tqphy(4), txphy(4), ukphy(4), urlphy(4), xmphy(4), ifconfig(8) MirOS BSD #10-current November 3, 1998 1
Generated on 2015-07-19 22:36:15 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.