ISP(4) BSD Programmer's Manual ISP(4)
isp - Qlogic based SCSI or FibreChannel SCSI Host Adapters
isp* at pci? dev ? function ? (PCI) isp* at sbus? slot ? offset ? (SBus) scsibus* at isp? option ISP_COMPILE_FW
This driver provides access to a SCSI bus or a FibreChannel connected to Qlogic ISP1000 (SBus), ISP1020 (PCI), ISP1040(PCI), ISP1080(PCI), ISP12160(PCI) SCSI host adapters or ISP2100(PCI), ISP2200(PCI) FibreChannel or ISP2300(PCI) 2-Gigabit FibreChannel host adapters. Features include support for UltraSCSI and wide mode transactions for SCSI, and Ultra2 LVD (for the ISP1080) and Ultra3 LVD (for the ISP12160) and the FCP SCSI (private loop, public loop or fabric) for FibreChannel. Command tagging is supported for all (in fact, FibreChannel requires tag- ging).
Adding option ISP_COMPILE_FW=1 to the kernel configuration file ensures that known good firmware will be downloaded to the driver at attach time. This is the default setting on sparc and sparc64 platforms, and is also recommended on platforms where the card's bios may not be initialized upon power-up.
cd(4), ch(4), intro(4), pci(4), sbus(4), scsi(4), sd(4), ses(4), ss(4), st(4), uk(4)
The isp driver was written by Matthew Jacob for NASA/Ames Research Center. MirOS BSD #10-current May 16, 2002 1
Generated on 2014-02-10 02:47:05 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.