ISAPNP(4) BSD Programmer's Manual ISAPNP(4)
isapnp - introduction to ISA Plug-and-Play support
isapnp0 at isa?
An isapnp bus can be configured for each supported ISA bus. OpenBSD provides machine-independent bus support and drivers for ISA Plug-and-Play (isapnp) autoconfiguration of PnP-compatible devices on an ISA bus.
OpenBSD includes machine-independent ISAPNP drivers, sorted by function and driver name:
aha(4) Adaptec AHA-154x SCSI controller card. aic(4) Adaptec AHA-1520B SCSI controller card. wdc(4) IDE controllers (typically found on sound cards).
com(4), pccom(4) 8250/16450/16550/16650/16850-compatible ISA PnP serial cards and internal modems. Winmodems are not supported.
an(4) Aironet 4500/4800 IEEE 802.11DS wireless interfaces. ef(4) 3Com 3c515 Fast EtherLink III Ethernet interfaces. ep(4) 3Com 3c509B EtherLink III Ethernet interfaces. le(4) Ethernet driver for Lance based Ethernet interfaces. ne(4) NE2000-compatible Ethernet interfaces. we(4) SMC EtherEZ Ethernet interfaces.
ess(4) ESS Technology AudioDrive 1788-, 1888-, 1887-, and 888-based sound cards. gus(4) Gravis Ultrasound PnP sound cards. mpu(4) MIDI interfaces. sb(4) SoundBlaster series sound cards (SB16 PnP through AWE64). wss(4) Windows Sound System cards. ym(4) Yamaha OPL3-SA3 sound cards.
joy(4) Joystick driver. pcic(4) ISA PCMCIA controllers. rt(4) AIMS Lab Radiotrack FM radio tuners.
aha(4), aic(4), cardbus(4), com(4), ef(4), ep(4), ess(4), gus(4), intro(4), isa(4), joy(4), le(4), mpu(4), ne(4), pci(4), pcic(4), pcmcia(4), rt(4), sb(4), usb(4), wdc(4), we(4), wss(4), ym(4)
The isapnp driver appeared in NetBSD 1.3.
From time to time an isapnp device will be found which the kernel does not recognize. The kernel matches isapnp devices to device drivers based on identifiers which each device provides. For example, this device: joy0 at isapnp0 <Creative SB16 PnP, CTL7001, PNPB02F, Game> port 0x200/8 This joystick calls itself by the two names "CTL7001" and "PNPB02F". The latter is a standard name (which the kernel automatically recognizes), but "CTL7001" is a vendor-specific name which needs to be added to a table. Unfortunately, some devices advertise only their vendor-specific name; for instance: isapnp0: <PnP Sound Chip, @P@1001, , > port 0x200/8 not configured Testing will show that this device is actually a joystick. To resolve the issue, the actual name "@P@1001" has to be entered into the database found in /sys/dev/isa/pnpdevs and a new kernel must be built. Then the device will probe like this: joy0 at isapnp0 <PnP Sound Chip, @P@1001, , > port 0x200/8 MirOS BSD #10-current July 12, 1998 1
Generated on 2014-02-10 02:47:05 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.