ICMP(4) BSD Programmer's Manual ICMP(4)
icmp - Internet Control Message Protocol
#include <sys/socket.h> #include <netinet/in.h> int socket(AF_INET, SOCK_RAW, proto);
ICMP is the error and control message protocol used by IP and the Inter- net protocol family. It may be accessed through a "raw socket" for net- work monitoring and diagnostic functions. The proto parameter to the socket call to create an ICMP socket is obtained from getprotobyname(3). ICMP sockets are connectionless, and are normally used with the sendto(2) and recvfrom(2) calls, though the connect(2) call may also be used to fix the destination for future packets (in which case the read(2) or recv(2) and write(2) or send(2) system calls may be used). Outgoing packets automatically have an IP header prepended to them (based on the destination address). Incoming packets are received with the IP header and options intact.
A socket operation may fail with one of the following errors returned: [EISCONN] when trying to establish a connection on a socket which already has one, or when trying to send a datagram with the destination address specified and the socket is al- ready connected; [ENOTCONN] when trying to send a datagram, but no destination ad- dress is specified, and the socket hasn't been connect- ed; [ENOBUFS] when the system runs out of memory for an internal data structure; [EADDRNOTAVAIL] when an attempt is made to create a socket with a net- work address for which no network interface exists.
recv(2), send(2), inet(4), ip(4), netintro(4)
The icmp protocol appeared in 4.3BSD. MirOS BSD #10-current June 5, 1993 1
Generated on 2015-07-19 22:36:15 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.