HME(4) BSD Programmer's Manual HME(4)
hme - Sun Happy Meal Ethernet
hme* at pci? dev ? function ? hme* at sbus? slot ? offset ? nsphy* at mii? phy ? qsphy* at mii? phy ?
The hme interface provides access to the 10Mb/s and 100Mb/s Ethernet net- works via the National DP83840 Ethernet 10/100 Mb/s Physical Layer or the Quality QS6612 Ethernet MII Transceiver for Category 5 Twisted Pair Cable chip sets. The hme is found on the SunSwift and Sun QuadFastEthernet boards. Each of the host's network addresses is specified at boot time with an SIOCSIFADDR ioctl(2). The hme interface employs the address resolution protocol described in arp(4) to dynamically map between Internet and Eth- ernet addresses on the local network. When a hme interface is brought up, by default, it will attempt to auto- negotiate the link speed and duplex. The speeds, in order of attempt, are: 100 Mb/s Full Duplex, 100 Mb/s Half Duplex, 10 Mb/s Full Duplex, and 10 Mb/s Half Duplex. The hme supports several media types, which are selected via the ifconfig(8) command. The supported media types are: media autoselect Attempt to autoselect the media type (default) media 100baseTX mediaopt full-duplex Use 100baseTX, full duplex media 100baseTX mediaopt half-duplex Use 100baseTX, half duplex media 10baseT mediaopt full-duplex Use 10baseT, full duplex media 10baseT mediaopt half-duplex Use 10baseT, half duplex
arp(4), be(4), ie(4), ifmedia(4), inet(4), intro(4), le(4), netintro(4), qe(4), sbus(4), hostname.if(5), ifconfig(8)
OpenBSD support for the hme first appeared in OpenBSD 2.4.
The hme sbus cards will not function in a sun4c class machine, due to PROM limitations. MirOS BSD #10-current October 5, 2001 1
Generated on 2014-02-10 02:47:05 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.