ARIA(4) BSD Programmer's Manual ARIA(4)
aria - Aria 16 audio device driver
aria0 at isa? port 0x280 irq 10 drq 0 flags 0x1
The aria driver provides support for sound cards based on Sierra Semiconductor's Aria chipset. Cards based on this chipset are capable of recording and playing 8- or 16-bit samples in mono or stereo up to 44.1KHz. Some chipsets only play linear or ADCPM, but others will also play Mu-law and A-law sounds. Three different mixer configurations are available. The I/O Port Base is selected from 0x280, 0x290, 0x2a0 and 0x2b0. The selection method depends on the board. The Aria takes 8 ports. The IRQ is selected from 10, 11, or 12. The DRQ line is chosen from 5 or 6, this driver will work with or without a DRQ. If no DRQ is given, then the aria driver will simply use Direct I/O. The flags currently supported are 0x1, for the Prometheus Aria 16/Aria 16se. This flag tells the driver to initialize the card. It is a weird and undocumented piece of horribleness, but the card will not respond un- til you twiddle with the joystick port.
audio(4), intro(4), isa(4)
Roland C. Dowdeswell <firstname.lastname@example.org>
The driver has only been tested on a Prometheus Aria 16. No DMA support, yet, so don't bother setting a DRQ. The full-duplex features are horribly inconsistent (i.e., unusable). The card sometimes drops out, and needs to be reset. This can be accom- plished by opening and closing /dev/audio, e.g., "echo -n >/dev/audio" The joystick and MIDI port interfaces are not supported. MirOS BSD #10-current January 21, 1996 1
Generated on 2015-07-19 22:36:15 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.