ADDCOM(4) BSD Programmer's Manual ADDCOM(4)
addcom - multiplexing serial communications interface
addcom0 at isa? port 0x108 irq 5 com* at addcom? slave ? or pccom* at addcom? slave ?
The addcom driver provides support for Addonics FlexPort 8/S (and prob- ably FlexPort 4/S) boards that multiplex together up to eight (or four) EIA RS-232C (CCITT V.28) communications interfaces. Each addcom device is the master device for up to eight com devices. The kernel configuration specifies these com devices as slave devices of the addcom device, as shown in SYNOPSIS. The slave ID given for each com dev- ice determines which bit in the interrupt multiplexing register is tested to find interrupts for that device. The port specification for the addcom device is used to compute the base addresses for the com subdevices. The port for the interrupt multiplexing register is fixed, so it is doubtful that more than one addcom can be used in a machine.
com(4), intro(4), isa(4)
OpenBSD support for addcom devices first appeared in OpenBSD 3.0. MirOS BSD #10-current July 16, 2001 1
Generated on 2015-10-06 19:36:22 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.