WSFONTLOAD(8) BSD System Manager's Manual WSFONTLOAD(8)
wssetfont - Set the font for a wscons display device
wssetfont [-c cfgdev] [-t ttydev] [name | -s slot]
The wssetfont utility set the specified console to use a font previously loaded with the wsfontload(8) utility. The font is specified either by name or by using the -s slot option. The options are as follows: -c cfgdev Specify the control device of the wscons display to operate on. Default is /dev/ttyCcfg. -t ttydev Specify the name of the tty console device to operate on. Default is the current console, i.e. the terminal device currently open on STDIN, as would be returned by tty(1). -s slot Specify to use the font currently loaded in slot. If neither a name or the -s slot option are given, the built in font for the device will be used.
# wsfontload -N myfont -e iso /usr/share/misc/pcvt/vt220l.816 # wssetfont -t /dev/ttyC0 myfont Load a font from the pcvt directory, and set the first console to use this font. # wssetfont Set the current console back to the default built in font.
wscons(4), wsconscfg(8), wsconsctl(8), wsfontload(8)
wssetfont appeared in MirOS #8.
If two fonts are given the same name when loaded, and both are valid for the current screen type, the first font will always be chosen, even if the -s slot option is used. Some devices may support the use of multiple fonts; this utility does not provide a method of setting more than one font for a given device. MirOS BSD #10-current February 28, 2004 1
Generated on 2015-10-06 19:36:22 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.