NCHECK_FFS(8) BSD System Manager's Manual NCHECK_FFS(8)
ncheck_ffs - generate names from inode-numbers
ncheck_ffs [-ams] [-f format] [-i number [...]] filesystem
ncheck_ffs generates a list of filenames and inode numbers for the given file system. Names of directories are followed by a '.'. The options are as follows: -a Print the file names '.' and '..', which are ordinarily skipped. -f format Use a custom output format when printing inode information. Char- acters from format are printed for each inode with the following escape sequences: \a Print a <bell> character. \b Print a <backspace> character. \e Print an <escape> character. \f Print a <form-feed> character. \I Print the inode number. \n Print a <new-line> character. \P Print the pathname to the file using the current inode number. \r Print a <carriage return> character. \t Print a <tab> character. \v Print a <vertical tab> character. \' Print a <single quote> character. \\ Print a backslash character. \0 Print a NUL character. All other characters, when prefixed by a backslash, simply print the character following the backslash. The device name is not printed on the first line of output when the -f option is speci- fied. -i number [...] Report only those files whose inode numbers are as listed. -m Give more verbose information on inodes. -s Report only special files and files with set-user-ID or set- group-ID set. This is meant to find hidden violations of security policies. The report is not sorted.
sort(1), fsck(8), fsdb(8)
The ncheck_ffs command was designed to be similar in functionality to the corresponding command in SunOS 4.1.3.
Thorsten Lockert <firstname.lastname@example.org> MirOS BSD #10-current June 24, 1996 1
Generated on 2015-10-06 19:36:22 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.