MRINFO(8) BSD System Manager's Manual MRINFO(8)
mrinfo - displays configuration info from a multicast router
mrinfo [-d debug_level] [-r retry_count] [-t timeout_count] multicast_router
mrinfo attempts to display the configuration information from the speci- fied multicast_router. mrinfo uses the ASK_NEIGHBORS IGMP message to the specified multicast router. If it router responds, the version number and a list of their neighboring multicast router addresses is part of the response. If the responding router has a recent multicast version number, then mrinfo re- quests additional information such as metrics, thresholds, and flags from the multicast router. Once the specified multicast router responds, the configuration is displayed to the standard output. The options are as follows: -d debug_level sets the debug level. When the debug level is greater than the default value of 0, additional debugging mes- sages are printed. Regardless of the debug level, an error condition will always write an error message and cause mrinfo to terminate. Non-zero debug levels have the following effects (printed to stderr): 1 packet warnings. 2 all level 1 messages plus notifications of down networks. 3 all level 2 messages plus notifications of all packet timeouts. -r retry_count sets the neighbor query retry limit. The default is to do 3 retries. -t timeout_count sets the number of seconds to wait for a neighbor query reply. The default timeout is 4 seconds.
# mrinfo mbone.phony.dom.net 127.148.176.10 (mbone.phony.dom.net) [version 3.3]: 127.148.176.10 -> 0.0.0.0 (?) [1/1/querier] 127.148.176.10 -> 127.0.8.4 (mbone2.phony.dom.net) [1/45/tunnel] 127.148.176.10 -> 22.214.171.124 (momoney.com) [1/32/tunnel/down] 127.148.176.10 -> 126.96.36.199 (mbone.dipu.edu) [1/32/tunnel] For each neighbor of the queried multicast router, the IP of the queried router is displayed, followed by the IP and name of the neighbor. In square brackets the metric (cost of connection), the threshold (multicast ttl) is displayed. If the queried multicast router has a newer version number, the type (tunnel, srcrt) and status (disabled, down) of the con- nection is displayed.
map-mbone(8), mrouted(8), mtrace(8)
Van Jacobson MirOS BSD #10-current May 8, 1995 1
Generated on 2015-07-19 22:36:15 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.