GROWFS(8) BSD System Manager's Manual GROWFS(8)
growfs - grow size of an existing ffs file system
growfs [-Ny] [-s size] special
The growfs utility extends the newfs(8) program. Before starting growfs the slice must be labeled to a bigger size using disklabel(8). If you wish to grow a file system beyond the boundary of the partition it re- sides in, you must re-size the partition using fdisk(8) before running growfs. The growfs utility extends the size of the file system on the specified special file. Currently growfs can only enlarge unmounted file systems. Do not try en- larging a mounted file system - your system may panic and you will not be able to use the file system any longer. Most of the newfs(8) options can- not be changed by growfs . In fact, you can only increase the size of the file system. Use tunefs(8) for other changes. The following options are available: -N Test mode. Causes the new file system parameters to be printed out without actually enlarging the file system. -s size Determines the size of the file system after enlarging in sec- tors. This value defaults to the size of the raw partition specified in special (in other words, growfs will enlarge the file system to the size of the entire partition). -y Expert mode. Usually growfs will ask you if you have taken a backup of your data and will test whether special is currently mounted. The -y flag suppresses this, so use this option with great care!
growfs -s 4194304 /dev/rwd0f will enlarge /dev/rwd0f up to 2GB if there is enough space in /dev/rwd0f.
The growfs utility works starting with FreeBSD 3.x. There may be cases on FreeBSD 3.x only, when growfs does not recognize properly whether or not the file system is mounted and exits with an error message ("nothing done"). Then please use growfs -y if you are sure that the file system is not mounted. The growfs utility has not yet been tested on OpenBSD at all, and not much on MirOS. They behave like FreeBSD 3.x in the respect shown above. It is also recommended to always use fsck(8) before and after enlarging (just to be on the safe side). For enlarging beyond certain limits, it is essential to have some free blocks available in the first cylinder group. If that space is not avail- able in the first cylinder group, a critical data structure has to be re- located into one of the new available cylinder groups. On FreeBSD 3.x this will cause problems with fsck(8) afterwards. So fsck(8) needs to be patched if you want to use growfs for FreeBSD 3.x. This patch is already integrated in FreeBSD starting with FreeBSD 4.4. To avoid an unexpected relocation of that structure it is possible to use ffsinfo -g 0 on the first cylinder group to verify that nbfree in the CYLINDER SUMMARY (internal cs) of the CYLINDER GROUP cgr0 has enough blocks. As a rule of thumb for default file system parameters one block is needed for every 2 GB of total file system size. Normally growfs writes this critical structure to disk and reads it again later for doing more updates. This read operation will provide unexpected data when using -N. Therefore, this part cannot really be simulated and will be skipped in test mode.
disklabel(8), dumpfs(8), fdisk(8), ffsinfo(8), fsck(8), newfs(8), tunefs(8)
The growfs utility first appeared in FreeBSD 4.4.
Christoph Herrmann <chm@FreeBSD.org> Thomas-Henning von Kamptz <tomsoft@FreeBSD.org> The GROWFS team <growfs@Tomsoft.COM>
It is recommended to always use fsck(8) after enlarging (just to be on the safe side). MirOS BSD #10-current September 8, 2000 1
Generated on 2014-02-10 02:47:05 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.