DHCLIENT(8) BSD System Manager's Manual DHCLIENT(8)
dhclient - Dynamic Host Configuration Protocol (DHCP) Client
dhclient [-dqu] [-c file] [-l file] interface
The dhclient utility provides a means for configuring network interfaces using DHCP, BOOTP, or if these protocols fail, by statically assigning an address. The name of the network interface that dhclient should attempt to config- ure must be specified on the command line. The options are as follows: -c file Specify an alternate location, file, for the configuration file. -d Forces dhclient to always run as a foreground process. By de- fault, dhclient runs in the foreground until it has configured the interface, and then will revert to running in the back- ground. -l file Specify an alternate location, file, for the leases file. -q Forces dhclient to be less verbose on startup. -u Forces dhclient to reject leases with unknown options in them. The default behaviour is to accept such lease offers. The DHCP protocol allows a host to contact a central server which main- tains a list of IP addresses which may be assigned on one or more sub- nets. A DHCP client may request an address from this pool, and then use it on a temporary basis for communication on the network. The DHCP proto- col also provides a mechanism whereby a client can learn important de- tails about the network to which it is attached, such as the location of a default router, the location of a name server, and so on. On startup, dhclient reads /etc/dhclient.conf for configuration instruc- tions. It then gets a list of all the network interfaces that are config- ured in the current system. It then attempts to configure each interface with DHCP. In order to keep track of leases across system reboots and server res- tarts, dhclient keeps a list of leases it has been assigned in the /var/db/dhclient.leases.IFNAME file. "IFNAME" represents the network in- terface of the DHCP client (e.g. em0), one for each interface. On start- up, after reading the dhclient.conf(5) file, dhclient reads the leases file to refresh its memory about what leases it has been assigned. Old leases are kept around in case the DHCP server is unavailable when dhclient is first invoked (generally during the initial system boot pro- cess). In that event, old leases from the dhclient.leases.IFNAME file which have not yet expired are tested, and if they are determined to be valid, they are used until either they expire or the DHCP server becomes available. A mobile host which may sometimes need to access a network on which no DHCP server exists may be preloaded with a lease for a fixed address on that network. When all attempts to contact a DHCP server have failed, dhclient will try to validate the static lease, and if it succeeds, it will use that lease until it is restarted. A mobile host may also travel to some networks on which DHCP is not available but BOOTP is. In that case, it may be advantageous to arrange with the network administrator for an entry on the BOOTP database, so that the host can boot quickly on that network rather than cycling through the list of old leases.
You must have the Berkeley Packet Filter (BPF) configured in your kernel. dhclient requires at least one /dev/bpf* file for each broadcast network interface that is attached to your system. See bpf(4) for more informa- tion.
/etc/dhclient.conf DHCP client configuration file /var/db/dhclient.leases.IFNAME database of acquired leases
bpf(4), dhclient.conf(5), dhclient.leases(5), dhclient-script(8), dhcp(8), dhcpd(8), dhcrelay(8)
dhclient was written by Ted Lemon <firstname.lastname@example.org> and Elliot Poger <email@example.com>. The current implementation was reworked by Henning Brauer <firstname.lastname@example.org>. MirOS BSD #10-current April 7, 2004 1
Generated on 2015-07-19 22:36:15 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.