HIER(7) BSD Reference Manual HIER(7)
hier - layout of filesystems
A sketch of the filesystem hierarchy. / Root directory. Home directory for the root user. /altroot/ Alternate (backup) location for the root ('/') filesystem (see afterboot(8)). /bin/ User utilities fundamental to both single and multi-user en- vironments. These programs are statically compiled and there- fore do not depend on any system libraries to run. /bsd Pure kernel executable (the operating system loaded into memory at boot-time). /bsd.mp Pure kernel executable for multi-processor machines. /bsd.rd Installation kernel. The built-in RAM disk contains utilities which can be run without an external file system, so this ker- nel is useful for limited system maintenance too. /dev/ Block and character device files. MAKEDEV Script for creating device files (see MAKEDEV(8)). fd/ File descriptor files (see fd(4)). /emul/ Base directory for alternate areas searched first when system call emulation is in effect (see sysctl(8) and the system com- pat pages: compat_linux(8) compat_openbsd(8)). /etc/ System configuration files and scripts. localtime Local timezone information (see ctime(3)). X11/ Configuration files for the X11 window system. authpf/ Configuration files for the authenticating gateway user shell (see authpf(8)). disklabels/ Backup disklabels (see disklabel(8)). firmware/ Firmware files for various devices. fonts/ Configuration files for X11 window system fonts. hotplug/ Scripts for the hotplug daemon, hotplugd(8). isakmpd/ Configuration files for isakmpd(8). mail/ sendmail(8) configuration files (including aliases(5)). mtree/ mtree configuration files (see mtree(8)). ppp/ pppd configuration files (see pppd(8)). raddb/servers/ List of radius servers and their associated shared secrets for login_radius(8). skel/ Example '.' (dot) files for new accounts. skey/ One-time password user database for skey(1). sliphome/ Configuration files for sliplogin(8). ssh/ Configuration files for ssh(1) and sshd(8). ssl/ OpenSSL configuration files (see openssl(1)). systrace/ Sample systrace(1) policies. /home/ Default location for user home directories. /mnt/ Empty directory commonly used by system administrators as a temporary mount point. /sbin/ System programs and administration utilities fundamental to both single and multi-user environments. These programs are statically compiled and therefore do not depend on any system libraries to run. /stand/ Programs used in a stand-alone environment. /tmp/ Temporary files; the contents of /tmp are not preserved across a system reboot. /usr/ Contains the majority of user utilities and applications. X11R6/ Files required for the X11 window system. bin/ X11 binaries. include/ X11-specific C include files. lib/ X11 archive libraries. X11/ Default configuration files for X11 and companion applications (see xdm(1), imake(1), setxkbmap(1), twm(1)). modules/ Various libraries and drivers for the X11 window system. man/ X11 manual pages. bin/ Common utilities, programming tools, and applica- tions. games/ Useful and semi-frivolous programs. include/ Standard C include files. altq/ C include files for the altq subsystem (see pf.conf(5)). arpa/ C include files for Internet service protocols. crypto/ C include files for the cryptographic libraries. ddb/ C include files for the kernel debugger (see ddb(4)). dev/ Device-specific C include files. isofs/ C include files for the ISO standard file systems (currently only cd9660). libmilter/ C include files for the sendmail(8) mail filter API. machine/ Machine specific C include files. miscfs/ C include files for miscellaneous file systems. net/ Miscellaneous network C include files. net80211/ C include files for 802.11 wireless net- working. netatalk/ C include files for the AppleTalk proto- col. netbt/ C include files for the Bluetooth proto- col. netinet/ C include files for Internet standard protocols (see inet(4)). netinet6/ C include files for Internet protocol version 6 (see inet6(4)). netipx/ C include files for the IPX protocol. netnatm/ C include files for native mode ATM ac- cess. nfs/ C include files for NFS (Network File System). openssl/ C include files for the OpenSSL library (see ssl(8)). protocols/ C include files for Berkeley service protocols. readline/ C include files for the readline(3) li- brary. rpc/ C include files for remote procedure calling (see rpc(5)). rpcsvc/ C include files for rpcsvc. scsi/ SCSI-specific C include files. sys/ System C include files (kernel data structures). ufs/ C include files for UFS (the U-word File System). uvm/ C include files for the virtual memory interface. lib/ System libraries. See intro(3) for a description of library types. libdata/ Miscellaneous utility data files. cvs/ Placeholder for user contributed cvs(1) code/scripts. ldscripts/ ELF linker scripts. lint/ Prebuilt lint(1) libraries. perl5/ Data files for perl(1). ssh/ Data file for ssh(1). libexec/ System daemons and utilities (executed by other pro- grams). auth/ Login scripts used to authenticate users (for BSD authentication). cvs/contrib/ User contributed cvs(1) scripts. lpr/ Contains the lpf filter for lpd(8). sendmail/ Contains the sendmail(8) binary. sm.bin/ Binaries to be run by smrsh(8). lkm/ Loadable kernel modules. local/ Local executables, libraries, etc. mdec/ Boot-related executables. obj/ Architecture specific target tree produced by build- ing the /usr/src tree. ports/ The OpenBSD ports collection (see ports(7)). sbin/ System daemons and utilities (executed by users). share/ Architecture independent data files. calendar/ Variety of pre-fab calendar files (see calendar(1)). dict/ Word lists (see look(1) and spell(1)). american Spellings preferred in American usage. english Spellings preferred in British usage. eign List of common words. propernames List of proper names. stop Forms that would otherwise be derivable by spell(1) from words in the other files in /usr/share/dict, but should not be accept- ed. web2 Words from Webster's 2nd International. web2a Additional words from Webster's. words Common words. papers/ Reference databases (see refer(1)). special/ Custom word lists. doc/ Miscellaneous documentation; source for most of the 4.3BSD manuals. html/ HTML documentation. psd/ UNIX Programmer's Supplementary Documents (PSD). smm/ UNIX System Manager's Manuals (SMM). usd/ UNIX User's Supplementary Docu- ments (USD). games/ ASCII text files used by various games. info/ Texinfo source files. ipsec/ IPsec example files. lkm/ Example source code implementing several lkm module types (see lkm(4)). man/ Manual pages. cat*/ Preformatted man(1) pages. Lay- out similar to man (below). man1/ General commands (tools and utilities). man2/ System calls and error numbers. man3/ Libraries. man3p/ perl(1) programmers' reference guide. man4/ Special files and hardware sup- port. man5/ File formats. man6/ Games. man7/ Miscellaneous. man8/ System maintenance and opera- tion commands. man9/ Kernel internals. misc/ Miscellaneous system-wide ASCII text files. termcap Terminal characteristics database (see termcap(5)). termcap.db Hash database file con- taining terminal descrip- tions (see cap_mkdb(1)). terminfo.db Terminal information data- base. pcvtfonts/ Additional i386 console fonts. mk/ Templates for make (see make(1)). pf/ Sample configuration files for pf(4). sendmail/ Example files for sendmail(8). tabset/ Tab description files for a variety of terminals; used in the termcap file (see termcap(5)). texinfo/ Templates for texinfo(5). tmac/ Text processing macros (see nroff(1) and troff(1)). vi/catalog/ Catalog files for the vi(1) text edi- tor. zoneinfo/ Timezone configuration information (see tzfile(5)). src/ BSD and/or local source files. bin/ Source for files in /bin. distrib/ Source for making distribution sets. etc/ Source for files in /etc. games/ Source for files in /usr/games. gnu/ Source for files under GPL or other res- trictive licenses. include/ Source for files in /usr/include. lib/ Source for files in /usr/lib. libexec/ Source for files in /usr/libexec. sbin/ Source for files in /sbin. share/ Source for files in /usr/share. sys/ Kernel source files. usr.bin/ Source for files in /usr/bin. usr.sbin/ Source for files in /usr/sbin. /var/ Multi-purpose log, temporary, transient, and spool files. account/ System accounting files. acct Execution accounting file (see acct(5)). audit/ Audit logs. authpf/ PID file for authpf(8). backups/ Miscellaneous backup files. crash/ Crash dumps written by savecore(8). cron/ Spools and configuration files for cron(8) and at(1). atjobs/ at(1) jobs. tabs/ Individual crontab(1) files. db/ Miscellaneous, automatically generated system- specific database files. empty/ Generic chroot(2) directory. games/ Miscellaneous game status and log files. log/ Miscellaneous system log files. wtmp Login/logout log (see wtmp(5)). mail/ User mailbox files. msgs/ Database for msgs(1). quotas/ Filesystem quota information files. run/ System information files describing various info about the system since it was booted. utmp Database of current users (see utmp(5)). sudo/ Timestamps for sudo(8). rwho/ rwho data files (see rwhod(8), rwho(1), and ruptime(1)). spool/ Miscellaneous printer and mail system spooling directories. clientmqueue/ Mail messages waiting to be pro- cessed by the sendmail clientmqueue helper task (see sendmail(8)). ftp/ Commonly ~ftp; the anonymous ftp root directory. lock/ Lock files for utilities such as cu(1), tip(1) and uucp. mqueue/ Undelivered mail queue (see sendmail(8)). output/ Line printer spooling directories. uucp/ uucp spool directory. uucppublic/ Commonly ~uucp; public uucp tem- porary directory. tmp/ Temporary files that are kept between system re- boots. www/ ServerRoot point for httpd(8).
apropos(1), find(1), locate(1), whatis(1), whereis(1), which(1)
A hier manual page appeared in Version 7 AT&T UNIX. MirOS BSD #10-current October 13, 2015 5
Generated on 2016-04-09 18:24:16 by $MirOS: src/scripts/roff2htm,v 1.83 2016/03/26 23:38:28 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2016 The MirOS Project, Germany.
This product includes material provided by mirabilos.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.