REMOTE(5) BSD Reference Manual REMOTE(5)
remote - remote host description file
The systems known by tip(1) and their attributes are stored in an ASCII file which is structured somewhat like the termcap(5) file. Each line in the file provides a description for a single remote host. Fields are separated by a colon (':'). Lines ending with a "\" character immediately followed by a newline are continued on the next line. The first entry is the name(s) of the host system. If there is more than one name for a system, the names are separated by vertical bars ('|'). After the name of the system comes the fields of the description. A field name followed by an equal sign ('=') indicates a string value follows. A field name followed by a pound sign ('#') indicates a following numeric value. Entries named "tip*" are used as default entries by tip(1) as follows. When tip(1) is invoked with only a baud rate, it looks for an entry of the form "tip<baud rate>". E.g. tip -300 will cause tip(1) to look for the system tip300.
Capabilities are either strings (str), numbers (num), or boolean flags (bool). A string capability is specified by capability=value; for exam- ple, "dv=/dev/harris". A numeric capability is specified by capability#value; for example, "xa#99". A boolean capability is specified by simply listing the capability. at (str) Auto call unit type. be (bool) Initialize the tip(1) variable "beautify" to on, so that non-printable characters will be discarded when scripting. br (num) The baud rate used in establishing a connection to the re- mote host. This is a decimal number. The default baud rate is 300 baud. cm (str) An initial connection message to be sent to the remote host. For example, if a host is reached through port selector, this might be set to the appropriate sequence required to switch to the host. cu (str) Call unit if making a phone call. Default is the same as the dv field. dc (bool) This host is directly connected, and tip(1) should not ex- pect carrier detect to be high, nor should it exit if carrier detect drops. di (str) Disconnect message sent to the host when a disconnect is requested by the user. du (bool) This host is on a dial-up line. dv (str) UNIX device(s) to open to establish a connection. If this file refers to a terminal line, tip(1) attempts to perform an ex- clusive open on the device to ensure only one user at a time has access to the port. ec (bool) Initialize the tip(1) variable "echocheck" to on, so that tip(1) will synchronize with the remote host during file transfer by waiting for the last character transmitted to echo. el (str) Characters marking an end-of-line. The default is NULL. "~" escapes are only recognized by tip(1) after one of the characters in el, or after a carriage-return. es (str) The escape character for tip(1). The default is "~". et (num) Number of seconds to wait for an echo response when "echocheck" mode is on. The default value is 10 seconds. ex (str) Set of non-printable characters not to be discarded when scripting with beautification turned on. The default value is "\t\n\b\f". fo (str) Character used to force literal data transmission. The de- fault value is '\020' (^P). fs (str) Frame size for transfers. The default frame size is equal to BUFSIZ. hd (bool) The host uses half-duplex communication, local echo should be performed. hf (bool) Initialize the tip(1) variable "hardwareflow" to on, so that hardware flow control (CRTSCTS) will be used for the connec- tion with the remote host. ie (str) Input end-of-file marks. The default is NULL. nb (bool) Initialize the tip(1) variable "beautify" to off, so that non-printable characters will not be discarded when scripting. nt (bool) Initialize the tip(1) variable "tandem" to off, so that XON/XOFF flow control will not be used to throttle data from the remote host. nv (bool) Initialize the tip(1) variable "verbose" to off, so that verbose mode will be turned off. oe (str) Output end-of-file string. The default is NULL. When tip(1) is transferring a file, this string is sent at end-of-file. pa (str) The type of parity to use when sending data to the host. This may be one of "even", "odd", "none", "zero" (always set bit 8 to zero), or "one" (always set bit 8 to 1). The default is no parity. pn (str) Telephone number(s) for this host. Either a list of arbi- trary dialing strings separated by commas, or a '@'. An at sign, '@', tells tip(1) to search the phones(5) database for the list of telephone numbers. For modems or auto-call units that use a ',' in their dialing strings (hayes, courier, t3000) tip(1) will convert any '=' in the string to a ',' when dialing. For modems or auto-call units that use a '=' in their dial strings, (v831), tip(1) will convert any '_' to a '=' when dialing. pr (str) Character that indicates end-of-line on the remote host. The default value is '\n'. ra (bool) Initialize the tip(1) variable "raise" to on, so that lowercase letters are mapped to uppercase before sending them to the remote host. rc (str) Character that toggles case-mapping mode. The default value is '\001' (^A). re (str) The file in which to record session scripts. The default value is tip.record. rw (str) Initialize the tip(1) variable "rawftp" to on, so that all characters will be sent as is during file transfers. sc (bool) Initialize the tip(1) variable "script" to on, so that everything transmitted by the remote host will be recorded. ta (bool) Initialize the tip(1) variable "tandem" to on, so that XON/XOFF flow control will be used to throttle data from the re- mote host. tb (bool) Initialize the tip(1) variable "tabexpand" to on, so that each tab will be expanded to 8 spaces during file transfers. tc (str) Indicates that the list of capabilities is continued in the named description. This is used primarily to share common capa- bility information. vb (bool) Initialize the tip(1) variable "verbose" to on, so that verbose mode will be turned on. Here is a short example showing the use of the capability continuation feature: UNIX-1200:\ :dv=/dev/cau0:el=^D^U^C^S^Q^O@:du:at=ventel:ie=#$%:oe=^D:br#1200: arpavax|ax:\ :pn=7654321%:tc=UNIX-1200
/etc/remote Global database.
The remote file format appeared in 4.2BSD. MirOS BSD #10-current June 5, 1993 2
Generated on 2016-01-17 04:51:01 by $MirOS: src/scripts/roff2htm,v 1.82 2016/01/02 20:05:08 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2016 The MirOS Project, Germany.
This product includes material provided by mirabilos.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.