NTPD.CONF(5) BSD Reference Manual NTPD.CONF(5)
ntpd.conf - Network Time Protocol daemon configuration file
This manual page describes the format of the ntpd(8) configuration file. It has the following format: Empty lines and lines beginning with the '#' character are ignored. Keywords may be specified multiple times within the configuration file. They are as follows: listen on address Specify a local IP address or a hostname the ntpd(8) daemon should listen on. If it appears multiple times, ntpd(8) will listen on each given address. If the exact string '*' is given as an address, ntpd(8) will listen on all local addresses. Other- wise, address can be followed by an asterisk ('*') and a UDP port number to listen on instead of the default 123. ntpd(8) does not listen on any address by default. For example: listen on * listen on 127.0.0.1 listen on ::1 server address Specify the IP address or the hostname of an NTP server to syn- chronize to. If it appears multiple times, ntpd(8) will try to synchronize to all of the servers specified. If a hostname resolves to multiple IPv4 and/or IPv6 addresses, ntpd(8) uses the first address. If it does not get a reply, ntpd(8) retries with the next address and continues to do so until a working address is found. For example: server 10.0.0.2 server ntp.example.org server ::1*12345 To provide redundancy, it is good practice to configure multiple servers. In general, best accuracy is obtained by using servers that have a low network latency. servers address As with server, specify the IP address or hostname of an NTP server to synchronize to. If it appears multiple times, ntpd(8) will try to synchronize to all of the servers specified. Should the hostname resolve to multiple IP addresses, ntpd(8) will try to synchronize to all of them. For example: servers pool.ntp.org
/etc/ntpd.conf default ntpd(8) configuration file
The ntpd.conf file format first appeared in OpenBSD 3.6. The serverloop keyword and the ability to specify a port first appeared in MirOS #10. MirOS BSD #10-current November 22, 2009 1
Generated on 2014-02-10 02:47:05 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.