GROUP(5) BSD Reference Manual GROUP(5)
group - format of the group permissions file
The file /etc/group consists of newline separated ASCII records, one per group, containing four colon (':') separated fields. These fields are as follows: group Name of the group. passwd Group's encrypted password. gid The group's decimal ID. member Group members. The group field is the group name used for granting file access to users who are members of the group. The gid field is the number associated with the group name. They should both be unique across the system (and often across a group of systems) since they control file access. The passwd field is an optional encrypted password. This field is rarely used and an asterisk is normally placed in it rather than leaving it blank. The member field contains the names of users granted the privileges of group. The member names are separated by commas without spaces or newlines. A user is automatically in a group if that group was specified in their /etc/passwd entry and does not need to be added to that group in the /etc/group file.
If YP is active, the group file may also contain lines of the format +name:*:: which causes the specified group to be included from the group.byname YP map. If no group name is specified, or the '+' (plus sign) appears alone on a line, all groups are included from the YP map. YP references may appear anywhere in the file, but the single '+' form should be on the last line, for historical reasons. Only the first group with a specific name encountered, whether in the group file itself, or included via YP, will be used.
passwd(1), setgroups(2), crypt(3), initgroups(3), passwd(5), yp(8)
A group file format appeared in Version 6 AT&T UNIX. The YP file format first appeared in SunOS.
The passwd(1) command does not change the group passwords. Lines in /etc/group are limited to 1024 characters. YP groups are not af- fected by this limit. Groups are limited to a maximum of 200 members per group. MirOS BSD #10-current July 18, 1995 1
Generated on 2015-07-19 22:36:15 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.