FBTAB(5) BSD Reference Manual FBTAB(5)
fbtab - change device protection upon login
The fbtab file contains lines which specify how the permissions and own- ership of various system files should be changed based on the user's lo- gin device name. Comments start with a '#' and extend to the end of the line. Blank lines or lines with only a comment are ignored. All other lines consist of three fields delimited by whitespace. Login Device The device you have logged in on (e.g., "/dev/ttyv0"). File Permission An octal permission number (0600), as used by chmod(2). Other devices The final field is a colon (':') delimited list of devices (e.g., "/dev/console:/dev/fd0a"). All dev- ice names are absolute paths. A path that ends in "/*" refers to all directory entries except "." and "..". The fbtab file is used by login(1) to chown(2) the specified files to the user who has performed a login. Additionally, chmod(2) is used to set the devices to the specified permission. When a user logs out, init(8) is responsible for performing the inverse operation, which results in the files once again belonging to root.
login(1), login_fbtab(3), init(8)
Guido van Rooij MirOS BSD #10-current August 22, 1994 1
Generated on 2014-02-10 02:47:05 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.