BOOTPARAMS(5) BSD Reference Manual BOOTPARAMS(5)
bootparams - boot parameter database
The bootparams file specifies the boot parameters that diskless(8) clients may request when booting over the network. Each client supported by this server must have an entry in the bootparams file containing the pathnames for its root and (optionally) swap areas. Each line in the file (other than comment lines that begin with a #) specifies the client name followed by the pathnames that the client may request by their logical names. The components of the line are delimited with blank or tab, and may be continued onto multiple lines with a backslash. For example: client root=server:/export/client/root \ swap=server:/export/client/swap \ dump=server:/export/client/swap In this version of rpc.bootparamd, client can be an asterisk ("*") for wildcard processing. When the client named "client" requests the pathname for its logical "root" it will be given the server name "server" and the pathname "/export/client/root" as the response to its RPC request. A line containing simply "+" will cause YP lookups to be done on the YP map "bootparams".
/etc/bootparams default configuration file
diskless(8), rpc.bootparamd(8), yp(8) MirOS BSD #10-current October 2, 1994 1
Generated on 2015-10-06 19:36:22 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.