WB(4) BSD Programmer's Manual WB(4)
wb - Winbond W89C840F Fast Ethernet driver
wb* at pci? dev ? function ?
The wb driver provides support for PCI Ethernet adapters and embedded controllers based on the Winbond W89C840F Fast Ethernet controller chip. This includes the Trendware TE100-PCIE and various other cheap boards. The 840F should not be confused with the 940F, which is an NE2000 clone and only supports 10Mbps speeds. The Winbond controller uses bus master DMA and is designed to be a DEC "tulip" work-alike. It differs from the standard DEC design in several ways: the control and status registers are spaced 4 bytes apart instead of 8, and the receive filter is programmed through registers rather than by downloading a special setup frame via the transmit DMA engine. Using an external PHY, the Winbond chip supports both 10 and 100Mbps speeds in either full or half duplex. The wb driver supports the following media types: autoselect Enable autoselection of the media type and options. This is only supported if the PHY chip attached to the Winbond con- troller supports NWAY autonegotiation. The user can manually override the autoselected mode by adding media options to the appropriate hostname.if(5) file. 10baseT Set 10Mbps operation. The mediaopt option can also be used to select either full-duplex or half-duplex modes. 100baseTX Set 100Mbps (Fast Ethernet) operation. The mediaopt option can also be used to select either full-duplex or half-duplex modes. The wb driver supports the following media options: full-duplex Force full duplex operation. half-duplex Force half duplex operation. Note that the 100baseTX media type is only available if supported by the adapter. For more information on configuring this device, see ifconfig(8).
wb%d: couldn't map memory A fatal initialization error has occurred. wb%d: couldn't map interrupt A fatal initialization error has occurred. wb%d: watchdog timeout The device has stopped responding to the network, or there is a problem with the network connection (cable). wb%d: no memory for rx list The driver failed to allocate an mbuf for the receiver ring. wb%d: no memory for tx list The driver failed to allocate an mbuf for the transmitter ring when allocating a pad buffer or collapsing an mbuf chain into a cluster. wb%d: chip is in D3 power state -- setting to D0 This message applies only to adapters which support power management. Some operating systems place the controller in low power mode when shutting down, and some PCI BIOSes fail to bring the chip out of this state before configuring it. The controller loses all of its PCI configuration in the D3 state, so if the BIOS does not set it back to full power mode in time, it won't be able to configure it correctly. The driver tries to detect this condition and bring the adapter back to the D0 (full power) state, but this may not be enough to return the driver to a fully operational condition. If this message appears at boot time and the driver fails to attach the device as a network interface, a second warm boot will have to be performed to have the device properly configured. Note that this condition only occurs when warm booting from another operating system. If the system is powered down prior to booting OpenBSD, the card should be configured correctly.
arp(4), ifmedia(4), intro(4), netintro(4), pci(4), hostname.if(5), ifconfig(8)
The wb device driver first appeared in FreeBSD 3.0. OpenBSD support first appeared in OpenBSD 2.5.
The wb driver was written by Bill Paul <firstname.lastname@example.org>.
The Winbond chip seems to behave strangely in some cases when the link partner switches modes. If, for example, both sides are set to 10Mbps half-duplex, and the other end is changed to 100Mbps full-duplex, the Winbond's receiver suddenly starts writing trash all over the RX descrip- tors. The wb driver handles this by forcing a reset of both the controll- er chip and attached PHY. This is drastic, but it appears to be the only way to recover properly from this condition. MirOS BSD #10-current November 4, 1998 1
Generated on 2015-10-06 19:36:22 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.