URIO(4) BSD Programmer's Manual URIO(4)
urio - USB driver for Diamond Multimedia Rio MP3 players
urio* at uhub? port ? configuration ?
The urio driver provides support for Rio500 and Rio600 MP3 players from Diamond MultiMedia. The driver implements minimal support to access the device and requires a user application for up and downloading music.
/dev/urio0 device node
Using the Rio500 package the command rio_add_song Rammstein-Wollt_Ihr_Das_Bett_In_Flammen_Sehen.mp3 will download a song over the USB connection into your Rio500.
uhub(4), usb(4) /usr/ports/audio/rio500
The urio driver appeared in OpenBSD 2.7. This driver is based on a FreeBSD Rio driver written by Iwasa Kazmi. MirOS BSD #10-current March 6, 2000 1
Generated on 2016-02-08 23:56:27 by $MirOS: src/scripts/roff2htm,v 1.82 2016/01/02 20:05:08 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2016 The MirOS Project, Germany.
This product includes material provided by mirabilos.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.