UMODEM(4) BSD Programmer's Manual UMODEM(4)
umodem - USB modem support
umodem* at uhub? port ? configuration ? ucom* at umodem?
The umodem driver provides support for USB modems in the Communication Device Class using the Abstract Control Model. These modems are basically standard serial line modems, but they are accessed via USB instead. They support a regular AT command set. The commands can either be multiplexed with the data stream or handled through separate pipes. In the latter case the AT commands have to be given on device separate from the data device. The device is accessed through the ucom(4) driver which makes it behave like a tty(4).
tty(4), ucom(4), uhub(4), usb(4)
The umodem driver appeared in NetBSD 1.5. OpenBSD support was added in OpenBSD 2.7.
Only modems with multiplexed commands and data are supported at the mo- ment. MirOS BSD #10-current August 16, 1999 1
Generated on 2016-01-17 04:51:01 by $MirOS: src/scripts/roff2htm,v 1.82 2016/01/02 20:05:08 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2016 The MirOS Project, Germany.
This product includes material provided by mirabilos.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.