TWE(4) BSD Programmer's Manual TWE(4)
twe - 3ware Escalade RAID driver
twe* at pci? dev ? function ? scsibus* at twe?
The twe driver provides support for Escalade family of RAID controllers, including the 3W-5x00 and 3W-6x00 models. These controllers support RAID 0, RAID 1, RAID 10 and JBOD configura- tions. All the RAID set volume management is done via the card BIOS. Even though the card uses IDE drives, this driver makes drives and/or RAID sets appear as sd(4).
intro(4), pci(4), scsi(4), sd(4)
The twe driver first appeared in OpenBSD 2.8.
The twe driver was written by Michael Shalayeff <firstname.lastname@example.org>, in- spired by the FreeBSD driver by Mike Smith <email@example.com>.
The card's BIOS seems to conflict with some other disk controllers which have their own BIOS, if such devices are configured earlier than this one. To avoid this situation, place twe cards in the lowest numbered slot before other SCSI or RAID disk controllers. The current 3ware firmware is known to fail if a redundant configuration is selected (RAID1 or RAID10) and the array is heavily used (e.g. instal- lation) before the controller has finished initializing the array. In this case, create the array, boot the installation media and leave the array idle until all controller activity has ceased. None of the volumes management or monitoring functions, provided by the card's firmware, is supported due to the fact that information on these functions is not public. Only 3W-5400 was tested, but others should work. MirOS BSD #10-current September 15, 2000 1
Generated on 2015-10-06 19:36:22 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.