SIS(4) BSD Programmer's Manual SIS(4)
sis - SiS 900, SiS 7016, and NS DP83815 Fast Ethernet driver
sis* at pci? dev ? function ?
The sis driver provides support for PCI Ethernet adapters and embedded controllers based on the Silicon Integrated Systems SiS 900 and SiS 7016 Fast Ethernet controller chips, as well as support for adapters based on the National Semiconductor DP83815 (MacPhyter) PCI Ethernet controller chip, including the Netgear FA311 and FA312. The SiS 900 is a 100Mbps Ethernet MAC and MII-compliant transceiver in a single package. It uses a bus master DMA and a scatter/gather descriptor scheme. The SiS 7016 is similar to the SiS 900 except that it has no internal PHY, requiring instead an external transceiver to be attached to its MII interface. The SiS 900 and SiS 7016 both have a 128-bit multicast hash filter and a single perfect filter entry for the station address. The NS DP83815 is also a 100Mbps Ethernet MAC with integrated PHY. The NatSemi chip and the SiS 900 share many of the same features and a fairly similar programming interface, hence both chips are supported by the same driver. The sis driver supports the following media types: autoselect Enable autoselection of the media type and options. The user can manually override the autoselected mode by adding media options to the hostname.if(5) file. 10baseT Set 10Mbps operation. The mediaopt option can also be used to select either full-duplex or half-duplex modes. 100baseTX Set 100Mbps (Fast Ethernet) operation. The mediaopt option can also be used to select either full-duplex or half-duplex modes. The sis driver supports the following media options: full-duplex Force full duplex operation. half-duplex Force half duplex operation. For more information on configuring this device, see ifconfig(8).
sis%d: couldn't map ports/memory A fatal initialization error has oc- curred. sis%d: couldn't map interrupt A fatal initialization error has occurred. sis%d: watchdog timeout The device has stopped responding to the net- work, or there is a problem with the network connection (cable). sis%d: no memory for rx list The driver failed to allocate an mbuf for the receiver ring. sis%d: no memory for tx list The driver failed to allocate an mbuf for the transmitter ring when allocating a pad buffer or collapsing an mbuf chain into a cluster. sis%d: chip is in D3 power state -- setting to D0 This message applies only to adapters which support power management. Some operating systems place the controller in low power mode when shutting down, and some PCI BIOSes fail to bring the chip out of this state before configuring it. The controller loses all of its PCI configuration in the D3 state, so if the BIOS does not set it back to full power mode in time, it won't be able to configure it correctly. The driver tries to detect this condition and bring the adapter back to the D0 (full power) state, but this may not be enough to return the driver to a fully operational condition. If this message appears at boot time and the driver fails to attach the device as a network interface, a second warm boot will have to be performed to have the device properly configured. Note that this condition only occurs when warm booting from another operating system. If the system is powered down prior to booting OpenBSD, the card should be configured correctly.
arp(4), ifmedia(4), intro(4), netintro(4), pci(4), hostname.if(5), ifconfig(8) SiS 900 and SiS 7016 datasheets, http://www.sis.com.tw. NatSemi DP83815 datasheet, http://www.national.com.
The sis device driver first appeared in FreeBSD 3.0. OpenBSD support was added in OpenBSD 2.7.
The sis driver was written by Bill Paul <email@example.com> and port- ed to OpenBSD by Aaron Campbell <firstname.lastname@example.org>. MirOS BSD #10-current September 4, 1999 1
Generated on 2015-07-19 22:36:15 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.