PCIBIOS(4) BSD Programmer's Manual (i386) PCIBIOS(4)
pcibios - introduction to PCI BIOS support
pcibios0 at bios0 flags 0x0000
OpenBSD provides support for setting up PCI controllers, bridges, and devices using information extracted from the BIOS. Ideally, the boot firmware of a machine (a.k.a. BIOS) should set up all PCI devices; assigning them I/O and memory addresses and interrupts. Alas, this does not always happen, so there is some PC specific code that can do the initialization when OpenBSD boots. Flags is a bit mask each bit of which specifies a fixup procedure to omit. The following list specifies these procedures and gives flags bit values to disable them in case they cause problems. 0x0001 Fixup PCI I/O and memory addresses. Some BIOS implementations don't allocate I/O space and memory space for all PCI devices. Especially, a BIOS which has "PnP OS mode" enabled shows this behavior. Since necessary space isn't allocated, those devices will not work without special handling. Without this flag force allocation of I/O space and memory space instead of relying upon the BIOS to do so. If necessary space is already correctly assigned to the devices, this option leaves the space as is. Although many BIOS implementations leave CardBus bridges' space unallocated, the CardBus bridge device driver doesn't require this option, since the driver allocates necessary space by it- self. 0x0002 Fixup PCI bus numbering; needed for many cardbus(4) bridges. Each PCI bus and CardBus should have a unique bus number. But some BIOS implementations don't assign a bus number for subordi- nate PCI buses. And many BIOS implementations don't assign a bus number for CardBuses. A typical symptom of this is the following boot message: cardbus0 at cardslot0: bus 0 device 0... Please note that this cardbus0 has a bus number '0', but normally the bus number 0 is used by the machine's primary PCI bus. Thus, this bus number for cardbus is incorrect (not assigned). In this situation, a device located in cardbus0 doesn't show correct dev- ice ID, because its bus number 0 incorrectly refers to the pri- mary PCI bus, and a device ID in the primary PCI bus is shown in the boot message instead of the device's ID in the cardbus0. Without this flag force assignment of bus numbers for all subor- dinate PCI buses and CardBuses. Since this procedure renumbers all PCI buses and CardBuses, all bus numbers of subordinate buses become different when this op- tion is enabled. 0x0004 Fixup PCI interrupt routing. Some BIOS implementations don't assign an interrupt for some dev- ices. This procedure assigns an interrupt for such devices instead of relying upon the BIOS to do so. If the BIOS has already assigned an interrupt to a device, this procedure leaves the interrupt as is. 0x0008 Make PCI interrupt routing fixup work with unknown interrupt routers. If this flag is specified and a PCI interrupt routing table entry indicates that only one IRQ is available for the en- try, the IRQ is assumed to be already connected to the device, and the corresponding PCI Interrupt Configuration Register will be configured accordingly. Without this flag, if a PCI interrupt router is not known, inter- rupt configuration will not be modified. 0x0010 Be verbose when performing pcibios tasks. Included in these diag- nostics are: PCI device address fixup tables, interrupt fixup re- ports, and other diagnostic and non-fatal messages. 0x0020 Make the PCI interrupt routing fixup procedure verbose. 0x0040 Force fixing up the PCIBIOS table. This is a MirOS extension, under OpenBSD you have to recompile your kernel with -DPCIBIOS_INTR_FIXUP_FORCE set in CFLAGS.
bios(4), intro(4), pci(4)
The pcibios code appeared in NetBSD 1.5. OpenBSD support was added in OpenBSD 2.8. In contrast to NetBSD implementation pcibios in OpenBSD is a real device, where options control is done through the flags which are modifiable through the boot_config(8) interface. For OpenBSD 2.9 the PCI interrupt routing establishment sequence was redone to only fixup and route interrupts when attaching interrupts for a particular PCI device.
The PCIBIOS Address Fixup option may conflict with the PCI CardBus driver's own address fixup. MirOS BSD #10-current July 22, 2000 1
Generated on 2015-07-19 22:36:15 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.