NCR(4) BSD Programmer's Manual NCR(4)
ncr - NCR/Symbios 53C8xx SCSI driver
ncr* at pci? dev ? function ? scsibus* at ncr? option FAILSAFE option NCR_CDROM_ASYNC option NCR_IOMAPPED option NCR_TEKRAM_EEPROM option NCR_VERBOSE=integer option SCSI_NCR_DFLT_TAGS=integer option SCSI_NCR_MAX_SYNC=integer option SCSI_NCR_MAX_WIDE=integer option SCSI_NCR_SYMBIOS_COMPAT option SCSI_NCR_TRUST_BIOS
The ncr driver provides support for the NCR (now Symbios) 53C810, 53C815, 53C820, 53C825, 53C860, 53C875, 53C876, 53C885, 53C895, 53C896, 53C1510, and 53C1510D SCSI controller chips. ncr is deprecated and has been replaced by the siop driver. The following kernel configuration options are available: option FAILSAFE Disables tagged command queuing and forces asynchronous transfers for CD-ROM devices. option NCR_CDROM_ASYNC Always use asynchronous transfers with CD-ROM devices. By default, syn- chronous transfers are used if the CD-ROM supports it. option NCR_IOMAPPED Attempt to access the controller chip via I/O port-mapped I/O, falling back to memory-mapped I/O if the I/O ports couldn't be mapped. By de- fault, memory-mapped I/O is tried first. option NCR_TEKRAM_EEPROM Enables support for reading the configuration EEPROM of the Tekram DC-390 series of SCSI cards. Enable this only if using a Tekram DC-390 card. option NCR_VERBOSE=integer Specifies the verbosity of driver messages during a kernel boot. A value of 1 will provide extra information about the controller's capabilities and setup. A value of 2 or greater will print information about the controller's registers. option SCSI_NCR_DFLT_TAGS=integer Specifies the maximum number of tags per logical unit. Unless FAILSAFE is defined, the default value is 4. A value of 0 will disable tagged command queuing. option SCSI_NCR_MAX_SYNC=integer Specifies the maximum synchronous transfer frequency to use, in kHz. A value of 0 means asynchronous transfers only. The default is 25000 (25MHz), but the actual value used depends on the type of controller chip and what its maximum transfer rate is. For controllers supporting fast transfers only, this is 10000 (10MHz). If wide transfers are supported, the value is 20000 (20MHz). option SCSI_NCR_MAX_WIDE=integer Specifies the maximum SCSI bus width, with 0 meaning 8 bits and 1 meaning 16 bits. Defaults to 1 on chips that support wide SCSI, 0 otherwise. Set this to 0 to disable wide transfers even if both controller and device support them (e.g. when using a wide controller and wide drive through a narrow cable). option SCSI_NCR_SYMBIOS_COMPAT Enables the use of the GPIO register as a disk activity indicator. Enable this if the activity LED isn't working, but make sure the card doesn't use GPIO for something else. Cards known to support this: ASUS SC875, Di- amond FirePort 40, and Symbios SYM8751S. option SCSI_NCR_TRUST_BIOS Specifies that the driver should use the register configuration set by the firmware instead of configuring the chip itself.
cd(4), ch(4), intro(4), pci(4), scsi(4), sd(4), siop(4), ss(4), st(4), uk(4)
Some Quantum drives (specifically the Atlas series) return "queue full" responses when a very small number of tags is used which can confuse the driver. With such drives, you can use option SCSI_NCR_DFLT_TAGS=0 in your kernel configuration file to disable tagged command queuing. MirOS BSD #10-current March 24, 2000 1
Generated on 2014-02-10 02:47:05 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.