MTIO(4) BSD Programmer's Manual MTIO(4)
mtio - magtape interface
This interface concerns devices which are typical tape block devices, see physio(9). The conventional device letters/numbers is applicable to any of the transport/controller pairs. (But note that only 1600 BPI is available with the TS11, and that 800 BPI is not applicable to TM78.) When the device last number is between 0-7 the device will operate at 800 BPI (or its lowest density), between 8-15 it will operate at 1600 BPI (or its second density), and between 16-23 it will operate at 6250 BPI. The rewind devices automatically rewind when the last requested read, write or seek has finished, or the end of the tape has been reached. The letter 'n' is usually prepended to the name of the no-rewind devices. Unix tapes are written in multiples of 1024 byte block records. Two end- of-file markers mark the end of a tape, and one end-of-file marker marks the end of a tape file. If the tape is not to be rewound it is positioned with the head in between the two tape marks, where the next write will overwrite the second end-of-file marker. All of the magtape devices may be manipulated with the mt(1) command. The include file <sys/mtio.h> defines the various ioctl(2) operations available on raw magnetic tape.
mt(1), tar(1), intro(4), st(4), wt(4)
The mtio manual appeared in 4.2BSD.
The status should be returned in a device independent format. MirOS BSD #10-current January 7, 1996 1
Generated on 2015-07-19 22:36:15 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.