LMC(4) BSD Programmer's Manual LMC(4)
lmc - Lan Media Corporation SSI/DS1/HSSI/DS3 card device driver
lmc* at pci? dev ? function ?
The lmc driver provides support for the Lan Media Corporation SSI, DS1, HSSI, and DS3 PCI WAN adapters based on the DEC 21140 Ethernet chip. The adapters use a DEC 21140 Ethernet chip for the PCI bus interface. Leaving the bus interface chip, the data path goes through a field programmable gate array, where HDLC processing is accomplished. Leaving the FPGA, there are FIFO buffers and the DS1, DS3, and V.35 drive circuitry. The intent is to provide a synchronous serial link with HDLC framing at speeds of up to 10Mbps (for the SSI card), 52Mbps (for the HSSI card), BNC connectors for 45Mbps operation without a CSU/DSU (DS3 card), and an RJ45 jack for T1/E1 operation without a CSU/DSU (DS1 card). The card will automatically use HDLC framing and defaults to external clock source. For the DS1 and DS3 cards with built-in CSU/DSU functional- ity, the clock source is always external (from CSU/DSU). The ability to set cable length is not currently implemented. Using the sppp(4) driver, you can also use the ppp protocol. In either case, the lmc interface should be configured as a point-to-point link.
lmc%d: couldn't map interrupt A fatal initialization error has occurred. lmc%d: couldn't establish interrupt A fatal initialization error has oc- curred. lmc%d: enabling keepalive Cisco HDLC keepalive packets will be transmit- ted. lmc%d: disabling keepalive Cisco HDLC keepalive packets will not be transmitted. lmc%d: clock internal The card is using internal clocking for the line. lmc%d: clock external The card is using external clocking for the line. lmc%d: asserting DTR and RTS The card is sending DTR and RTS signals on the line. lmc%d: deasserting DTR and RTS The card is not sending DTR and RTS sig- nals on the line. lmc%d: Abnormal interrupt The card received an incomplete request. This may be a sign of a hardware fault. lmc%d: tx_intr: failed to dequeue mbuf?!? Only available if compiled with LMC_DEBUG. lmc%d: txput: tx not running Problem from tulip. Only available if com- piled with LMC_DEBUG.
netintro(4), sppp(4), ifconfig(8), lmccontrol(8) Lan Media Corporation has a web site with data, descriptions, and pic- tures of their cards at www.lanmedia.com.
The lmc device driver was written by Michael Graff, and was derived in part from Matt Thomas' de(4) driver. The OpenBSD port and manual page are from Chris Cappuccio. Later enhancements to support the LMC1200 card are based on LMC's Linux driver. MirOS BSD #10-current October 15, 1999 1
Generated on 2014-02-10 02:47:05 by $MirOS: src/scripts/roff2htm,v 1.79 2014/02/10 00:36:11 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002‒2014 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.