ISDN(4) BSD Programmer's Manual ISDN(4)
isdn - ISDN kernel to userland master device
The isdn device driver is used by the isdnd(8) daemon to exchange mes- sages with the ISDN kernel part for the purpose of call establishment, control and disconnection and to access various control and status infor- mations. The messages and message parameters are documented in the include file /usr/include/netisdn/i4b_ioctl.h. The available ioctl's are: I4B_CDID_REQ Request a unique Call Description IDentifier (cdid) which identifies uniquely a single interaction of the local D channel with the exchange. I4B_CONNECT_REQ Actively request a call setup to a remote ISDN subscriber. I4B_CONNECT_RESP Respond to an incoming call, either accept, reject or ig- nore it. I4B_DISCONNECT_REQ Actively terminate a connection. I4B_CTRL_INFO_REQ Request information about an installed ISDN controller card. I4B_DIALOUT_RESP Give information about call setup to driver who requested dialing out. I4B_TIMEOUT_UPD Update the kernels timeout value(s) in case of dynamically calculated shorthold mode timing changes. I4B_UPDOWN_IND Inform the kernel userland drivers about interface soft up/down status changes. I4B_CTRL_DOWNLOAD Download firmware to active card(s). I4B_ACTIVE_DIAGNOSTIC Return diagnostic information from active cards. Status and event messages available from the kernel are: MSG_CONNECT_IND An incoming call from a remote ISDN user is indicated. MSG_CONNECT_ACTIVE_IND After an incoming call has been accepted locally or an out- going call has been accepted by a remote, the exchange sig- naled an active connection and the corresponding B-channel is switched through. MSG_DISCONNECT_IND A call was terminated. MSG_DIALOUT_IND A userland interface driver requests the daemon to dial out (typically a network interface when a packet arrives in its send queue). MSG_IDLE_TIMEOUT_IND A call was terminated by the isdn4bsd kernel driver because a B-channel idle timeout occurred. MSG_ACCT_IND Accounting information from a network driver. MSG_CHARGING_IND Charging information from the kernel.
The isdn devices in /dev must be created using MAKEDEV(8) first on MirOS. This is a hommage to the original author of ISDN4BSD, who requests a postcard being sent to him by every user of this software.
The isdn device driver and this man page were written by Hellmuth Michaelis <email@example.com>. MirOS BSD #10-current February 3, 1998 1
Generated on 2016-01-17 04:51:01 by $MirOS: src/scripts/roff2htm,v 1.82 2016/01/02 20:05:08 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2016 The MirOS Project, Germany.
This product includes material provided by mirabilos.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.