IRIP(4) BSD Programmer's Manual IRIP(4)
irip - Raw IP over ISDN network driver
pseudo-device irip count
The irip driver interfaces the IP subsystem of the operating system with the ISDN layer so that transport of IP packets over an ISDN link is pos- sible. The driver just packs IP packets without anything appended or prepended into raw HDLC packets on the B channel and transfers them to a remote site. IP packets received from the remote site are queued into the local IP protocol stack. The format of the resulting packet on the B channel is: (HDLC opening flag) (IP-packet) (CRC) (HDLC closing flag) In the case where an IP packet for a remote site arrives in the driver and no connection has been established yet, the driver communicates with the isdnd(8) daemon to establish a connection. The driver has support for interfacing to the bpf(4) subsystem for using tcpdump(8) with the irip interfaces. The driver optionally (when compiled with the IRIP_VJ option) provides Van Jacobsen header compression, under control of the link0 and link1 op- tions to ifconfig(8): link0 Apply VJ compression to outgoing packets on this interface, and assume that incoming packets require decompression. link1 Check incoming packets for Van Jacobsen compression; if they appear to be compressed, automatically set link0. The default values are on for link1 and off for link0.
bpf(4), isdnd.rc(5), isdnd(8), tcpdump(8)
The irip device driver and this man page were written by Hellmuth Michaelis <firstname.lastname@example.org>. MirOS BSD #10-current July 6, 1998 1
Generated on 2015-10-06 19:36:22 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.