IPPP(4) BSD Programmer's Manual IPPP(4)
ippp - ISDN synchronous PPP network driver
pseudo-device ippp count
The ippp driver interfaces the IP subsystem of the operating system with the ISDN layer so that a transport of IP packets over an ISDN link is possible. For configuration of the ippp driver, either the ipppctl(8) utility is used or it is configured via isdnd(8) and its associated isdnd.rc(5) file. In case an IP packet for a remote side arrives in the driver and no con- nection is established yet, the driver communicates with the isdnd(8) daemon to establish a connection. The driver has support for interfacing to the bpf(4) subsystem for using tcpdump(8) with the ippp interfaces. The ipppctl(8) utility is used to configure all aspects of PPP required to connect to a remote site.
The link0 and link1 flags given as parameters to ifconfig(8) have the following meaning for the ippp devices: link0 Wait passively for connection. The administrative Open event to the Link Control Protocol (LCP) layer will be delayed until after the lower layers signal an Up event (rise of "carrier"). This can be used by lower layers to support a dial-in connection where the physical layer isn't available immediately at startup, but only after some external event arrives. Receipt of a Down event from the lower layer will not take the interface completely down in this case. link1 Dial-on-demand mode. The administrative Open event to the LCP layer will be delayed until either an outbound network packet ar- rives, or until the lower layer signals an Up event, indicating an inbound connection. As with passive mode, receipt of a Down event (loss of carrier) will not automatically take the interface down, thus it remains available for further connections. The link0 flag is set to off by default, the link1 flag to on.
bpf(4), isdnd.rc(5), ipppctl(8), isdnd(8), tcpdump(8)
The ippp device driver was written by Joerg Wunsch <email@example.com> and then added to ISDN4BSD by Gary Jennejohn <firstname.lastname@example.org>. This man page was written by Hellmuth Michaelis <email@example.com>. MirOS BSD #10-current August 31, 2000 1
Generated on 2015-07-19 22:36:15 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.