GDT(4) BSD Programmer's Manual GDT(4)
gdt - Intel and ICP-Vortex GDT RAID driver
gdt* at pci? dev ? function ? scsibus* at gdt?
The gdt driver provides support for all currently known ICP Vortex adapters: GDT4x13RZ, GDT4x23RZ, GDT6000/6020/6050, GDT6000B/6010, GDT6110/6510, GDT6120/6520, GDT6513RS, GDT6518RS, GDT6523RS, GDT6530, GDT6535, GDT6537, GDT6537RP, GDT6537RP1, GDT6537RP2, GDT6550, GDT6555, GDT6557, GDT6557RP, GDT6557RP1, GDT6557RP2, GDT6x11RP, GDT6x11RP1, GDT6x11RP2, GDT6x15, GDT6x17, GDT6x17RP, GDT6x17RP1, GDT6x17RP2, GDT6x18RD, GDT6x19RD, GDT6x21RP, GDT6x21RP1, GDT6x21RP2, GDT6x25, GDT6x27, GDT6x27RP, GDT6x27RP1, GDT6x27RP2, GDT6x28RD, GDT6x28RS, GDT6x29RD, GDT6x33RS, GDT6x38RD, GDT6x38RS, GDT6x43RS, GDT6x53RS, GDT6x58RD, GDT6x58RS, GDT6x63RS, GDT7x13RN, GDT7x18RN, GDT7x19RN, GDT7x23RN, GDT7x28RN, GDT7x29RN, GDT7x38RN, GDT7x43RN, GDT7x53RN, GDT7x58RN, GDT7x63RN, GDT8x00RZ, GDT8x13RZ, GDT8x14RZ, GDT8x22RZ, GDT8x23RZ, GDT8x23RZ, GDT8x24RZ, GDT8x33RZ, GDT8x43RZ, GDT8x46RZ, GDT8x53RZ, GDT8x63RZ, and GDT8x86RZ. Also supported, are select Intel RAID controllers containing firmware derived from ICP Vortex. Although the controllers are actual RAID controllers the driver makes them look just like SCSI controllers. All RAID configuration is done through the controllers' BIOSes.
pci_mem_find: expected mem type 00000000, found 00000002 This message occurs during autoconfiguration if jumper J4 is set to map the controller memory below 1MB in physical memory. The driver primarily wants this jumper to be set the other way round, but it will work with it in any setting. If the diagnostic is considered a nuisance, alter jumper J4's setting.
intro(4), pci(4), scsi(4), sd(4)
The gdt driver first appeared in OpenBSD 2.7.
The gdt driver was written by Niklas Hallqvist <email@example.com>, in- spired by the Linux driver by Achim Luebner <firstname.lastname@example.org>.
An ISA front-end is needed. The driver does not yet support transparent raw SCSI mode. It would be nice to configure the RAID units after boot but the informa- tion on how to do that is not public. MirOS BSD #10-current February 17, 2000 1
Generated on 2015-10-06 19:36:22 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.