BKTR(4) BSD Programmer's Manual BKTR(4)
bktr - video capture driver
bktr* at pci? dev ? function ? radio* at bktr? option BKTR_ALLOC_PAGES=nnn option BKTR_SYSTEM_DEFAULT=XXX option BKTR_OVERRIDE_CARD=nnn option BKTR_OVERRIDE_MSP=n option BKTR_OVERRIDE_TUNER=nnn
The bktr driver provides support for PCI video capture and VBI capture on low cost, high performance boards. This should support most video cards based on the Brooktree Bt848/849/878/879 Video Capture Chip. The driver also supports FM Radio if the Tuner supports it. Specifically, the following cards are known to work: Animation Technologies FlyVideo Askey/Dynalink Magic TView AverMedia cards Hauppauge Wincast TV and WinTV/PCI IMS TV Turbo Intel Smart Video Recorder III I/O DATA GV-BCTV2/PCI KISS TV/FM PCI Leadtek Winfast TV 2000 Miro PC TV MMAC Osprey NEC PK-UG-X017 STB TV PCI Television Tuner Terratec TerraTVplus Video Highway XTreme VideoLogic Captivator PCI Zoltrix TV The driver currently supports the following features: PCI to PCI DMA transfer clipping yuv rgb16 rgb24 rgb32 On these cards, tuners and other components are interconnected with an I2C bus. The Brooktree848 chips act as a master device on the bus to con- trol them. The following kernel configuration options are available: option BKTR_ALLOC_PAGES=nnn Specifies the number of contiguous pages to allocate when suc- cessfully probed. The default number of pages allocated by the kernel is 216. This means that there are (216*4096) bytes available for use. option BKTR_SYSTEM_DEFAULT="(BROOKTREE_PAL | BROOKTREE_NTSC)" One of these options can be used to set the default video for- mat for the driver. This fixed random hangs and lockups with the VideoLogic Captivator PCI card. option BKTR_OVERRIDE_CARD=nnn Select a specific card (overrides autodetection). `nnn' is set to one of the names listed and explained below. ASKEY_DYNALINK_MAGIC_TVIEW Askey/Dynalink Magic TView AVER_MEDIA AverMedia FLYVIDEO Animation Technologies FlyVideo HAUPPAUGE Hauppauge Wincast TV and WinTV IMS_TURBO IMS TV Turbo INTEL Intel Smart Video Recorder III IO_GV I/O DATA GV-BCTV2/PCI KISS KISS TV/FM PCI LEADTEK Leadtek Winfast TV 2000 MIRO Miro PC TV OSPREY MMAC Osprey NEC_PK NEC PK-UG-X017 STB STB TV PCI Television Tuner TERRATVPLUS Terratec TerraTVplus VIDEO_HIGHWAY_XTREME Video Highway XTreme ZOLTRIX Zoltrix TV option BKTR_OVERRIDE_MSP=n Specifies whether the MSP3400C chip is present (overrides auto- detection). option BKTR_OVERRIDE_TUNER=nnn Select a specific tuner (overrides autodetection). `nnn' is set to one of the names listed and explained below. TEMIC_NTSC Temic 4032FY5 TEMIC_PAL Temic 4002FH5 TEMIC_SECAM Temic 4002FN5 PHILIPS_NTSC Philips FI1236 PHILIPS_PAL Philips FM1216 PHILIPS_SECAM Philips FI1216MF TEMIC_PALI Temic 4062FY5 PHILIPS_PALI Philips FI1246 PHILIPS_FR1236_NTSC Philips FR1236 MK2 PHILIPS_FR1216_PAL Philips FM1216 PHILIPS_FR1236_SECAM Philips FM1216MF ALPS_TSCH5 Apls TSCH5 NTSC ALPS_TSBH1 Apls TSBH1 NTSC
intro(4), pci(4), radio(4)
The bktr driver first appeared in FreeBSD 2.2.
The bktr driver is based on the work of Jim Lowe <firstname.lastname@example.org>, Mark Tinguely <email@example.com>, Amancio Hasty <firstname.lastname@example.org>, Roger Hardiman <roger@FreeBSD.org> and a bunch of other people.
On big-endian architectures it is not possible to program the card to perform proper byte swapping in 24 bit modes, therefore only 16 and 32 bit modes are supported. MirOS BSD #10-current January 28, 1998 2
Generated on 2016-02-08 23:56:27 by $MirOS: src/scripts/roff2htm,v 1.82 2016/01/02 20:05:08 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2016 The MirOS Project, Germany.
This product includes material provided by mirabilos.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.