BIOS(4) BSD Programmer's Manual (i386) BIOS(4)
bios - a driver for PC Firmware, aka BIOS
bios0 at mainbus0 flags 0x0000 apm0 at bios0 flags 0x0000 pcibios0 at bios0 flags 0x0000
OpenBSD provides support for PC firmware, aka BIOS and some of its func- tions, currently: APM subsystem, BIOS 32 extensions, PCI BIOS subsystem. The bios driver also identifies BIOS type (such as "AT/286+", which is almost always used in modern machines) and BIOS image date stamp, which is, presumably, the day the BIOS image was compiled by vendor and could be used as a crude BIOS version identification. The bios driver also scans the ISA memory hole at 640K-1M for optional ROM images and reserves the space from being used by various ISA devices, for example pcic(4). Flags is a bit mask each bit of which specifies which functions of the driver to disable. 0x0001 BIOS 32 attachment. Do not probe and attach to BIOS 32 extensions, which is one of the interfaces to the PCI BIOS configuration tables. 0x0002 PCI BIOS attachment. Do not probe and attach the pcibios(4) device, which performs certain PCI configuration tasks. 0x0004 Do not perform the scan for ROM images in the ISA memory hole (0xc0000 - 0xf0000 physical addresses).
apm(4), intro(4), pcibios(4), pcmcia(4), powernowhack(4)
The bios driver appeared in OpenBSD 2.2.
On some machines optional ROM images do not pass checksum check, but it's considered better to reserve space for those anyway, choosing lesser evil from many. MirOS BSD #10-current February 28, 2001 1
Generated on 2015-10-06 19:36:22 by $MirOS: src/scripts/roff2htm,v 1.80 2015/01/02 13:54:19 tg Exp $
These manual pages and other documentation are copyrighted by their respective writers;
their source is available at our CVSweb,
AnonCVS, and other mirrors. The rest is Copyright © 2002–2015 The MirOS Project, Germany.
This product includes material provided by Thorsten Glaser.
This manual page’s HTML representation is supposed to be valid XHTML/1.1; if not, please send a bug report – diffs preferred.